Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: No Pressure, no suction, New Pump - Please Help

  1. Back To Top    #1

    No Pressure, no suction, New Pump - Please Help

    I have a new pump and I am getting little to no suction. I get the same thing when I just recirculate. I know I keep getting a lot of air in the filter. What could be the problem? This is driving me crazy
    Nancy

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879
    Welcome to TFP!

    That sounds like an air leak on the suction side of the pump. The first thing to check is the pump strainer basket lid. The lid needs to have a clean seal, fit properly, be properly tightened down. After that look at the plumbing connections to the pump and any pipe that was replaced when the pump was replaced.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    RE: No Pressure, no suction, New Pump - Please Help

    Thank you!

    I checked to make sure the lid fit properly and tightened down. I checked the plumbing connections to the pump and they look good and tight. I have 3 skimmers and the are all full of water.
    Nancy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •