Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: new sand pump problem

  1. Back To Top    #1

    new sand pump problem

    OK I bought the intex Krystal clear 2650 gph pump for my 16x48 pool. It just got above the pool outlet so we did the backwash and rinse and everything they way the manual said and then switched it to filter. The water was shooting half way across the pool out of the little jet, and water was spewing from the sides of the strainer. I took the strainer off and in the inside of it, the holes on the outside of the movable jet there is like plastic covering them seems to be stopping alot of water flow. Is it OK to remove this plastic because it looks like its supposed to be there.

  2. Back To Top    #2
    linen's Avatar
    Join Date
    Jul 2010
    Twin Cities, MN

    Re: new sand pump problem

    Welcome to tfp, Wdustin1

    Are you talking the "screen" in the center of this part?:

    I would think you could break out some of that screen, then it would be more like a traditional eyeball fitting.
    TFP Expert who uses Pool School and my TF100 test kit along with PoolMath for my: Round 11K gallon AGP with deep end, 20" sand filter, Matrix 1hp 2spd, 6 2ftX20ft solar panels (and solar cover!), Intex SWCG (copper bars disconnected) and a Rubadub hot tub (chlorine). The SLAM process is not finished until: 1. CC < 0.5 ppm, 2. An OCLT < 1.0 ppm and, 3. The water is crystal clear.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts