Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 13 of 13

Thread: WhisperFlo won't prime...HELP!!

  1. Back To Top    #1

    WhisperFlo won't prime...HELP!!

    WhisperFlo 1 1/2 hp pump won't prime on its own anymore!! It was intermittent at first, but over the past few months it has gotten to the point where it will not prime without filling it with water ( sometimes 3 or more , that is shutting everything down, filling the pump and turning it back on, before we can get water flow). The skimmer basket is clean, the cartridges in the Pentair Clean & Clear plus 420 are clean and the manifold is seated firmly, I just replaced the gasket on the filter housing & the pump lid gasket (pool lube included) after installing gaskets and refilling pump, it primed fairly fast, however after shutting down for the night, it wouldn't prime....again!

  2. Back To Top    #2

    Join Date
    Feb 2008
    Location
    Denton, TX
    Posts
    5,061

    Re: WhisperFlo won't prime...HELP!!

    Welcome to TFP!

    Did you recently clean your filter cartridges? Just making sure that you tightened the barrel nut assembly enough. You know you have tightened it enough when you can no longer see light between the spring coils. Another thing to check is that your pressure gauge on top of the filter doesn't need changing. If you shut the pump off and you can hear a slight hiss of air at the pressure gauge, the gauge should be replaced.

  3. Back To Top    #3

    In the Industry

    Join Date
    Nov 2011
    Location
    Moberly,MO
    Posts
    978

    Re: WhisperFlo won't prime...HELP!!

    Your issue is from the lint pot lid back to the pool. Somewhere on the suction side you are getting air into it and it is unable to prime. When the pump was running ok did you evernotice when you shut it off water leaking out of the plumbing?
    Over 30 years in the pool business
    We build vinyl, fiberglass, stainless steel pools
    Certified in Hydraulics

  4. Back To Top    #4

    Re: WhisperFlo won't prime...HELP!!

    I just watched my husband prime the pool, first off, he waits oh maybe a minute, perhaps 2, before he shuts it down opens the pump and fills the check valve and pump, replaces the lid and turns it back on. He repeats this process until it primes!!! Adding to that our timer is failing and needs to be replaced, asap. So at this point I'm not entirely certain that the pool WONT prime on its own without further investigation. I intend to do that tomorrow and I will let you know, we have many issues with our pool that I need advice and guidance for so I WILL be back.

  5. Back To Top    #5

    Re: WhisperFlo won't prime...HELP!!

    Sometimes he does this process 5-10 times he tells me!

  6. Back To Top    #6

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,077

    Re: WhisperFlo won't prime...HELP!!

    Fix that suction side leak and your pump will prime. In a perfectly leak proof circulatory system (hard to accomplish but possible) the pump will NEVER lose prime.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  7. Back To Top    #7

    Re: WhisperFlo won't prime...HELP!!

    (FYI our pool equipment sits about 8-10 ft above the pool)Okay, so today I went out and ( the pump was full when I began) I switched it on set a timer for 10 min. and waited. Then I started off by taking the pump lid and cleaning it thoroughly, then applying pool lube generously inside the lid, filled the pump with water, opened the pressure valve on top of the filter and set the timer for 5min, no go. Then I closed the filter valve, filled the pump, then I went to the skimmer and put a hose into the port inside and turned the water on full blast, fired it up...no go. It took about 30 min of off & on and refilling the pump before I was able to prime it. I have an obvious suction issue! I did not notice any leaks at the pump, but the way the equipment is set up( fully exposed to weather, with leaves,etc. around it, it isn't easy to spot) I fully intend to build some kind of shed around it, as it should have had anyway! I will take some pictures of the pool and the equipment today, and hopefully post them later this evening. Then I'm hoping you can give me a place to start.

  8. Back To Top    #8

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,077

    Re: WhisperFlo won't prime...HELP!!

    8-10 feet above the pool is pretty helpful advice. You will ALWAYS have a hard time priming that pump if you have even the tiniest air leak.

    You are going to have to install check valves to prevent that water at the pump and filter from going back to the pool. If you have them already, they are not working.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  9. Back To Top    #9
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: WhisperFlo won't prime...HELP!!

    Actually, if the pump was full with water while the pump was off, that seems to indicate that you may not have any leaks (at least on the pressure side that may allow the water to drain back to the pool).

    Or maybe I do not understand since it then sounds like you turn the pump on for 10 minutes and nothing happens?

    I agree with Dave, every time you open the pump and the suction line drains that far down, it is going to be hard to get it re-primed. Adding a check valve on the suction side seems to make a lot of sense in this case.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  10. Back To Top    #10

    Re: WhisperFlo won't prime...HELP!!

    My wife joined the forum last year and is having trouble accessing her acct, so I joined as well. She is the one with experience, her Dad was in the industry for 40 years, she spent many of her summers helping her Dad with his route in Palos Verdes, CA. I am a California State licensed Electrical contractor since 1992, I grew up on the beach in So. Cal. My wife and I moved to Nevada City, CA almost 14 years ago and last year moved into a home less than a mile from our old one…one of the major differences being the in ground swimming pool! If my wife didn’t have the same background we wouldn’t have approached the prospect/ project as confidently…the previous owners authorized the disconnection of the existing solar heating system(apparently they were unable to find anyone more qualified than a neighbor claiming to be a “pool guy”). He also disconnected the drain(????) there is a waterfall as well. My wife submitted photos last year, seeking advice on plumbing corrections, which I will post again, to give a fuller picture of our pump issues. My wife also stated that when she shut the pool done the other night, she could hear several “loud, popping & hissing coming from the equipment” she could not tell whether it was coming from the filter or the check valve before the pump, she thinks it was the valve. We are capable people, but this is rapidly going over our heads!! Please help!! [size=75
    ]
    [/size]

  11. Back To Top    #11
    Isaac-1's Avatar
    Join Date
    May 2010
    Location
    SW Louisiana
    Posts
    6,711

    Re: WhisperFlo won't prime...HELP!!

    Don't worry we will get you there, it does sound like you have some type of leak, just not sure exactly what yet. Suction side leaks are the worst because they are so hard to spot and even a little pin hole leak can keep a pump from priming right. One trick that can help locate the source of your problem is to use good old fashion shaving cream around suspected leaks, look for it to be sucked in, but also look for soapy bubbles on the return water once the pump is primed.
    Indoor 20x40 35,000 gallon vinyl pool with 1.5 HP 2 speed Jandy FloPro pump, Hayward EC75 Perflex DE filter, 11 4x12 Techno-Solis solar panels w/ Aquasolar controller, Aquabot Turbo T Robot Cleaner. Also LMI metering chlorine dispenser pump and HotSpring Jetsetter
    I use and endorse TFtestKits TF-100 from http://tftestkits.net
    ~Remember TFP counts on your donations to keep this site ad free~

  12. Back To Top    #12

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,077

    Re: WhisperFlo won't prime...HELP!!

    My wife also stated that when she shut the pool done the other night, she could hear several “loud, popping & hissing coming from the equipment” she could not tell whether it was coming from the filter or the check valve before the pump, she thinks it was the valve.
    Is this a new problem or a part of your existing won't prime" issue?

    The suction side of that system is gonna' have to be airtight to keep you from dropping prime. You may well have more than one leak but there's no doubt that you have it (them). You will need to methodically track them down, get them sealed, and your system will operate.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  13. Back To Top    #13
    Smykowski's Avatar
    Join Date
    Sep 2011
    Location
    Gurnee, IL (North Suburban Chi-town)
    Posts
    3,065

    Re: WhisperFlo won't prime...HELP!!

    Quote Originally Posted by GC
    I am a California State licensed Electrical contractor since 1992...
    Awesome!! There are a lot of "How do I wire...?" questions that pop up on this forum.

    The collective knowledge here is unsurpassed, and we'll help you through it. Just pay it forward with your electrical knowledge when the time comes .
    33' round, 23,000 gal AG vinyl , 1HP 2spd PowerFlo Matrix downsized with 3/4HP impeller (X2), Hayward S180T 150# sand filter (X2), Hayward H250 NG heater Pool Store year 1 - $850 for 2 months; Pool Store year 2 - $440 for 2 months, TFPC year 1 - $170 for 4 months; TFPC year 2 - $95 for 4.5 months
    The most important article on this site - The ABCs of Pool Water Chemistry

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •