I have a Jandy Aque Link v3.0 and every now and then it just quits working. the pda say "waiting" but won"t connect. I've turned off power at the breaker for a few minutes (even tried overnight once) and nothing. If I take out the screws that hold the top control panel in place and manipulate the panel I'll see the panel lights start to flash and if I can get it back in fast it it might be ok for a few days or even a month. Once it is going the time and date are always reset to default, and sometimes the whole pda is reset (temperatures, programs etc.). yesterday when it did it the aux that is asigned to the waterfall no longer works. you can hear the relay click in the box but it doesn't change the valve. if you move the switch at the valve it rotates to the off/on position, but still no reaction to the pda.

I have a feeling there is/are loose or bad wires, but where do I begin? is the issue a power supply or a front board?

I am so frustrated with Jandy and their products. With the help of this forum I finally got the Chlorine generator going a few months back. No help from Jandy!