Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: pump loses prime

  1. Back To Top    #1

    pump loses prime

    above ground pool w/ Hayward DE 50 filter and a Matrix Pro 1.5hp pump ... installed as a single unit & it is approx 8-10 years old .. am losing prime to pump daily.. can re-prime and runs Ok until it shuts off at days end ... when it restarts the next AM, the prime is lost .. I can open the top of the pump, re-prime, & it starts right up
    altho pump filter tank does not completely fill with water ... have checked and replaced the pump filter compartment glass top O ring .. no help ... fill and return lines to pool are underground and do not see any wet spots .. neither pump or filter is showing any leakage ...... how can I find my air leak ???
    - shayle

  2. Back To Top    #2

    Join Date
    Aug 2011
    Location
    Gainesville, fl
    Posts
    53

    Re: pump loses prime

    My guess is it is one of the underground ones has a slight crack. Not big enough to leave any wet marks but just enough to lose prime. Had the same thing happen to me with a well pump. I was fine as long as there was a draw on the pump, as soon as the pump shut off the prime went away. Turned out to be a crack in the line where it went back into the ground to come to the house.
    12"x33" Summer Escapes AG Ring Quick set 1590 Gallons (Gift for my son by Grand-parents)
    Intex Krystal Clear Model 633 2500 GPH "B" Cartridge

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: pump loses prime

    Is the equipment above the waterline? Most above ground pools have the equipment at or below the waterline.

    Are there any valves in the suction line from the skimmer to the pump?
    Make sure the skimmer weir is operating correctly.
    Make sure the skimmer isn't creating a vortex when the pump is running.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  4. Back To Top    #4

    Re: pump loses prime

    WILL HAVE TO CHECK LINES MORE CLOSELY.......
    <<< FOR DAVE J *****
    have 1 valve in line which I have had checked and was told it is working correctly ... no problem with skimmer weir .. skimmer sometimes does create a vorex when starting.. have watched it and it does not seem to cause any problems ... what causes a vortex ??? is it to strong a pump ???

  5. Back To Top    #5
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: pump loses prime

    Quote Originally Posted by SHAYLEH
    what causes a vortex ??? is it to strong a pump ???
    Could be either the pump is too strong or the water level is too low.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  6. Back To Top    #6
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: pump loses prime

    On our pool, it will create a vortex if the weir sticks, if the water level gets too low, or if the skimmer basket gets left out. Creating a vortex means that air is getting into the filter, and if it isn't self purging, it will force air back through the pump when it's shut off and empty the pump of water causing it to lose prime.

    What type filter do you have?

    Since there is a valve on the suction, I would check it carefully for a leak. If you're getting bubbles in the pump basket when it's running you can run water over the valve and fittings to see if it stops the bubbles.

    You said you replaced the pump basket, but did you remove and reseal the drain plug in the pump volute housing? If not it might be worth doing.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •