Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Hayward Aquarite Turning On and Off

  1. Back To Top    #1

    Hayward Aquarite Turning On and Off

    I have a Hayward Aquarite that was purchased in 2003. I replaced the cell about 6 months ago and it was working great. Now the control unit seems to be having issues:

    First the reading was at 2700 but the pool was closer to 3000, power and generating lights were on.
    Then the reading went to 0 and the Power and Generating green lights would stay on for about 10 seconds, I would hear a click from behind the panel face and then the lights would go off. About 1 minute later they would come on and then click off again. The reading would stay at 0

    I am fairly capable at DIY and would love to replace or diagnose just what is wrong rather then having to buy a whole new unit.

    Any help would be GREATLY appreciated.


  2. Back To Top    #2

    Re: Hayward Aquarite Turning On and Off

    I found lots of dialog on DIY replacing the current limiter on Aqua Rite. Simple solder job & $8 part. Might do the trick. See my post today with an upgrade alternative: solder once, then future plug & play current limiter installation. Picture included.
    KenShu, Houston TX: 18.5Kgallon in-ground plaster pool+spa, Hayward DE48 filter, AquaRite SWG, AOSmith 1.5HP pump, Hayward 350KBTU heater, Polaris360, TFTTestKit.

  3. Back To Top    #3

    Re: Hayward Aquarite Turning On and Off

    Thanks for getting back to me. I did replace the limiter and all is well now. Just like many others, a $2 part saved me $400! Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts