Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Waterco hydrostorm pump not priming?

  1. Back To Top    #1

    Waterco hydrostorm pump not priming?

    Hi there,

    I'm a new member to the forum & looking for some guidance and advice please. We just moved into a new house with an IG tiled pool approx 35000 litres with a Waterco hydrostorm pump, chlorination and cartridge filter.

    All has been eking really well over the last month, but in the last few days I have noticed that the pump hasn't been running when it should have been. When I checked the equipment I saw that there is power going to the pump and the timer is 'telling' the pump to run, however nothing happening. Interestingly when I touch the pump its very hot to touch, even though it isn't running...

    Just as I called a mobile pool service to come for a site visit, the pump started working...! This was about 2 hours after its scheduled start time...same thing happened today as well, although this time it took about an hour and a half after the scheduled start time for it to start running...same thing, the pump wasn't running but was very hot to touch.

    I have made sure that the hair and lint bowl was full, the fan on the pump spins freely and as far as I can tell there are no air leeks....does anyone have any possible suggestions? Is it something electrical that will need to be repaired? I'm getting the mobile pool people to come out later this week anyway so they can give me a 1:1 on how to use everything correctly, but would be good to have some possible ideas before they come out.

    Many thanks,
    Scott.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,345

    Re: Waterco hydrostorm pump not priming?

    Is it humming when it tries to start? If so it's probably the start capacitor. Getting hot is normal when it tries to start and can't for whatever reason.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Re: Waterco hydrostorm pump not priming?

    Hi Bama Rambler,

    Thanks for the reply, really appreciate it.

    Yes actually, it does hum...but usually just the once and then even when I restart the timer to try to get it going, it often doesn't hum again but continues to heat up even though it isn't running.

    Would it be the capacitor if for some reason it starts up later in the day...?

    Many thanks,
    Scott.

  4. Back To Top    #4
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,345

    Re: Waterco hydrostorm pump not priming?

    It could be or it could be the centrifugal switch contacts. It also could be something binding the impeller. Have you tried turning the shaft by hand?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  5. Back To Top    #5

    Re: Waterco hydrostorm pump not priming?

    Hi Dave,

    Yes I can turn the pump by hand by removing the fan cover and spinning the fan, it seems to turn pretty easily....the strange thing is that when the pump is schedule to turn on, it doesn't and makes that whirring sound and then nothing happens, however I have noticed say an hour or two later, the pump is running....it's as if it re-sets itself and starts up ok....sounds like something electrical perhaps?

  6. Back To Top    #6
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,345

    Re: Waterco hydrostorm pump not priming?

    Once it doesn't start, it gets hot and then the thermal cutout trips, then it cools down and the cutout resets and it keeps cycling until it starts or burns up.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •