Become a TFP Supporter Pool Math Forum Rules Pool School
Page 1 of 2 12 LastLast
Results 1 to 20 of 31

Thread: Viewing unread doesn't keep track properly

  1. Back To Top    #1

    Join Date
    Mar 2007
    Location
    San Rafael, CA USA
    Posts
    12,082

    Viewing unread doesn't keep track properly

    I noticed that recently clicking on the viewing unread messages for a thread doesn't work quite right. It doesn't always seem to remember the last point that was read. It sometimes selects a post further up so shows ones that have been already read. It doesn't start from the top of the thread so it does recognize some things being read. And if I go back and refresh the page, the unread symbol goes away as it should.
    16,000 gallon outdoor in-ground 16'x32' plaster pool; Pentair Intelliflo VF pump; Pentair IntelliTouch i9+3s control system; Jandy CL-340 square foot cartridge filter
    12 Fafco solar panels; Purex Triton PowerMax 250 natural gas heater (200,000 BTU/hr output); automatic electric pool safety cover; 4-wheel pressure-side "The Pool Cleaner"

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,331

    Re: Viewing unread doesn't keep track properly

    Which browser and OS are you using?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Join Date
    Mar 2007
    Location
    San Rafael, CA USA
    Posts
    12,082

    Re: Viewing unread doesn't keep track properly

    Safari 6.0.2 on Mac OS 10.8.2
    16,000 gallon outdoor in-ground 16'x32' plaster pool; Pentair Intelliflo VF pump; Pentair IntelliTouch i9+3s control system; Jandy CL-340 square foot cartridge filter
    12 Fafco solar panels; Purex Triton PowerMax 250 natural gas heater (200,000 BTU/hr output); automatic electric pool safety cover; 4-wheel pressure-side "The Pool Cleaner"

  4. Back To Top    #4

    Join Date
    Oct 2011
    Location
    Frisco, TX
    Posts
    47

    Re: Viewing unread doesn't keep track properly

    Its happening on tapatalk on android too. Other forums are OK.
    Size 13,000 gal | Filtration Jandy DE 60 | Sanitation PLC1400 SWG, Rainbow 320 | Placement in-ground (IG) | Coping Tennessee Crab Orchard
    Finish pebble smooth Tahoe Blue | Pumps Intelliflo VS+SVRS 3.0HP main | Lighting Jandy LED Spa/Pool
    Location Frisco TX US

  5. Back To Top    #5
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Viewing unread doesn't keep track properly

    I have been trying to duplicate the problem here, but so far it has been working for me.

    I assume you have been using the "First unread post" link towards the top right, just above the "Author Message" sub-heading?
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  6. Back To Top    #6

    Join Date
    Mar 2007
    Location
    San Rafael, CA USA
    Posts
    12,082

    Re: Viewing unread doesn't keep track properly

    No, I have been using the "Your posts" or "New posts by date" and then clicking on the symbol to the left of the thread name, such symbols only being present for new unread posts. The symbols correctly disappear if I refresh that screen or click on "Your posts" or "New posts by date" (whichever was done originally) again, but if a new post gets added to the thread then the next time it shows up in New posts by date with the symbol, clicking on the symbol won't go to the new post -- it will go to the older post as if I didn't go into the thread to look at it before.

    This problem happened with this very thread as well.
    16,000 gallon outdoor in-ground 16'x32' plaster pool; Pentair Intelliflo VF pump; Pentair IntelliTouch i9+3s control system; Jandy CL-340 square foot cartridge filter
    12 Fafco solar panels; Purex Triton PowerMax 250 natural gas heater (200,000 BTU/hr output); automatic electric pool safety cover; 4-wheel pressure-side "The Pool Cleaner"

  7. Back To Top    #7
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Viewing unread doesn't keep track properly

    I think I found it. It appears to be a bug in Safari.

    The forum software is correctly figuring out the post to display and correctly making a URL for that post, but the browser is displaying something else. If you go to this link, you should get to renovxpt's first post, and in Firefox you do. But in Safari, you usually end up at Knollbrook's third post, much higher up in the sequence. From what I can see, Safari is picking a scroll position based on the topic without images. Then as the images load the text gets pushed down and you end up in the wrong place. Occasionally it even blinks in the correct position for a moment, and then pops to the wrong position. Once the page has loaded, if you select the URL bar in the browser and press return it takes you to the correct position (at least most of the time).
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  8. Back To Top    #8

    Join Date
    Mar 2007
    Location
    San Rafael, CA USA
    Posts
    12,082

    Re: Viewing unread doesn't keep track properly

    Got it. Well, at least there is the workaround of clicking the link and pressing enter to reload the page after images have been loaded (clicking on the "reload the current page" circular arrow symbol doesn't always work). Thanks for figuring this out. I used to use Firefox, but got a new laptop and have switched to using Safari. That explains why the problem seemed to start happening with that switch.
    16,000 gallon outdoor in-ground 16'x32' plaster pool; Pentair Intelliflo VF pump; Pentair IntelliTouch i9+3s control system; Jandy CL-340 square foot cartridge filter
    12 Fafco solar panels; Purex Triton PowerMax 250 natural gas heater (200,000 BTU/hr output); automatic electric pool safety cover; 4-wheel pressure-side "The Pool Cleaner"

  9. Back To Top    #9
    UnderWaterVanya's Avatar
    Join Date
    Jun 2012
    Location
    Mint Hill, NC
    Posts
    2,589

    Re: Viewing unread doesn't keep track properly

    I have seen something similar in. IE 8 and Tapatalk (multiple platforms) it seems to be more of an issue in threads with a lot of pictures. I will try to let you know when I see it again.
    Inlaws Pool Boy since June 14th 2012, Pool built ~ 2003, In-Ground, 16'x32'
    13500 gal, Vinyl Liner, Fiberglass Slide, TF-100 Test Kit, Hayward 210T
    sand filter, A.O. Smith 1.5HP main pump motor (C48L2N134C1),
    Hayward SuperPump (model ?), Polaris 380 & PB4 Booster Pump

  10. Back To Top    #10

    Join Date
    Mar 2007
    Location
    San Rafael, CA USA
    Posts
    12,082

    Re: Viewing unread doesn't keep track properly

    There's something more going on here. With this current thread, when I go back into it after "Your posts" and clicking on the symbol to the left of the thread name, it gives me the following link:

    viewing-unread-doesn-t-keep-track-properly-t55025.html#p452299

    which is to the second post in this thread (which, by the way, has no images in the posts). So this isn't just Safari and it's not going to the right place, though that is indeed a separate problem. The workaround of clicking on the URL and trying again doesn't work in this case.
    16,000 gallon outdoor in-ground 16'x32' plaster pool; Pentair Intelliflo VF pump; Pentair IntelliTouch i9+3s control system; Jandy CL-340 square foot cartridge filter
    12 Fafco solar panels; Purex Triton PowerMax 250 natural gas heater (200,000 BTU/hr output); automatic electric pool safety cover; 4-wheel pressure-side "The Pool Cleaner"

  11. Back To Top    #11
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Viewing unread doesn't keep track properly

    Curious. I haven't seen that happen yet. I'll keep watching for it and see if I can pin down what is happening.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  12. Back To Top    #12
    UnderWaterVanya's Avatar
    Join Date
    Jun 2012
    Location
    Mint Hill, NC
    Posts
    2,589

    Re: Viewing unread doesn't keep track properly

    This thread using Tapatalk has worked for me so far. The pictures thing I mentioned may not be causing the problem as much as exposing it by making it easy to see.

    Sent via Tapatalk...
    Inlaws Pool Boy since June 14th 2012, Pool built ~ 2003, In-Ground, 16'x32'
    13500 gal, Vinyl Liner, Fiberglass Slide, TF-100 Test Kit, Hayward 210T
    sand filter, A.O. Smith 1.5HP main pump motor (C48L2N134C1),
    Hayward SuperPump (model ?), Polaris 380 & PB4 Booster Pump

  13. Back To Top    #13
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Viewing unread doesn't keep track properly

    I finally saw this fail in the second way (wrong post number), which seems much less common than failing in the first way (image height). Again the cause was a Safari issue. Safari was caching the last time I clicked the first unread post link for that page and not accessing the server at all. There is a no-cache command on those results already. I added a different no-cache command to the page header to see if I can force Safari to not cache the page, but it happens so rarely for me that I haven't been able to test it in a meaningful way yet. Plus, anything already cached before my change will still cause problems.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  14. Back To Top    #14

    Join Date
    Mar 2007
    Location
    San Rafael, CA USA
    Posts
    12,082

    Re: Viewing unread doesn't keep track properly

    Whatever you did worked better for me since this time for this thread I went directly to your message. So it seems you've worked around Safari's bug, at least the post number / caching bug (not the timing wait for images to load before positioning bug).
    16,000 gallon outdoor in-ground 16'x32' plaster pool; Pentair Intelliflo VF pump; Pentair IntelliTouch i9+3s control system; Jandy CL-340 square foot cartridge filter
    12 Fafco solar panels; Purex Triton PowerMax 250 natural gas heater (200,000 BTU/hr output); automatic electric pool safety cover; 4-wheel pressure-side "The Pool Cleaner"

  15. Back To Top    #15
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Viewing unread doesn't keep track properly

    Good.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  16. Back To Top    #16
    UnderWaterVanya's Avatar
    Join Date
    Jun 2012
    Location
    Mint Hill, NC
    Posts
    2,589

    Re: Viewing unread doesn't keep track properly

    I finally have a concrete example I can share:

    I opened this thread from the "your posts" link using IE 9:
    newbie-about-to-start-t54771-40.html#p452664

    This is the post I was taken to:
    newbie-about-to-start-t54771-40.html#p452194

    This is the last post I recall reading seeing prior to this visit and also the one that matches the last date I was on the site using TapaTalk or IE 9 either one:
    newbie-about-to-start-t54771-40.html#p452215

    EDIT: Revisiting that thread after posting this using the first URL in this post took me to the correct post. So I'm at a loss as to explain why it behaved that way once and only once.
    Inlaws Pool Boy since June 14th 2012, Pool built ~ 2003, In-Ground, 16'x32'
    13500 gal, Vinyl Liner, Fiberglass Slide, TF-100 Test Kit, Hayward 210T
    sand filter, A.O. Smith 1.5HP main pump motor (C48L2N134C1),
    Hayward SuperPump (model ?), Polaris 380 & PB4 Booster Pump

  17. Back To Top    #17
    UnderWaterVanya's Avatar
    Join Date
    Jun 2012
    Location
    Mint Hill, NC
    Posts
    2,589

    Re: Viewing unread doesn't keep track properly

    Another one:

    This thread:
    newbie-closing-pool-in-houston-t54599.html#p452968

    Using "your posts" link took me to this post from Dec 13th 2012:
    newbie-closing-pool-in-houston-t54599.html#p448897

    It should have taken me here to this post from January 7th 2013:
    newbie-closing-pool-in-houston-t54599.html#p452968


    And another:

    This thread: newbie-about-to-start-installing-swcg-t54771-40.html#p452990
    Took me to this post: newbie-about-to-start-installing-swcg-t54771-40.html#p452664
    But this is the correct post it should have delivered me to:http://www.troublefreepool.com/newbi...0.html#p452990
    Inlaws Pool Boy since June 14th 2012, Pool built ~ 2003, In-Ground, 16'x32'
    13500 gal, Vinyl Liner, Fiberglass Slide, TF-100 Test Kit, Hayward 210T
    sand filter, A.O. Smith 1.5HP main pump motor (C48L2N134C1),
    Hayward SuperPump (model ?), Polaris 380 & PB4 Booster Pump

  18. Back To Top    #18
    UnderWaterVanya's Avatar
    Join Date
    Jun 2012
    Location
    Mint Hill, NC
    Posts
    2,589
    Inlaws Pool Boy since June 14th 2012, Pool built ~ 2003, In-Ground, 16'x32'
    13500 gal, Vinyl Liner, Fiberglass Slide, TF-100 Test Kit, Hayward 210T
    sand filter, A.O. Smith 1.5HP main pump motor (C48L2N134C1),
    Hayward SuperPump (model ?), Polaris 380 & PB4 Booster Pump

  19. Back To Top    #19
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Viewing unread doesn't keep track properly

    That particular kind of detail doesn't really help. What would be more interesting to know is, when it fails and you go back to the previous page and follow the link again do you end up in the same place? And if so, if you exit the browser, launch it again, and then try the link again what happens.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  20. Back To Top    #20
    UnderWaterVanya's Avatar
    Join Date
    Jun 2012
    Location
    Mint Hill, NC
    Posts
    2,589

    Re: Viewing unread doesn't keep track properly

    Quote Originally Posted by JasonLion
    That particular kind of detail doesn't really help. What would be more interesting to know is, when it fails and you go back to the previous page and follow the link again do you end up in the same place? And if so, if you exit the browser, launch it again, and then try the link again what happens.
    I'll check. I can check those threads now and report back on what they do now. I have not closed the browser since earlier.
    Inlaws Pool Boy since June 14th 2012, Pool built ~ 2003, In-Ground, 16'x32'
    13500 gal, Vinyl Liner, Fiberglass Slide, TF-100 Test Kit, Hayward 210T
    sand filter, A.O. Smith 1.5HP main pump motor (C48L2N134C1),
    Hayward SuperPump (model ?), Polaris 380 & PB4 Booster Pump

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •