Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pentair Legend Platinum

  1. Back To Top    #1

    Join Date
    Jul 2007
    Katy, TX

    Pentair Legend Platinum

    My legend seems to be getting stuck at 2 certain points at my steps. It has never done this before. I replaced one set of tread tires as the ones on the back had no more tread. I switched the older ones to the back and put new ones on front. It climbs nicely and I have seen it go up steps and float away. However there seems to be two specific area at my steps that it will just sit. Any suggestions? How can I test the back up valve? Thanks!

    24,000 IG with spa and 4 ton waterfall. Equipment: Pentair 520 Clean & Clear, Pentair VS+SVRS Intelliflo, Pentair Whisperflo 2 HP, Polairis Cleaner, Intellibrites, Pentair Rainbow 320 in-line Chlorinator, Pentair Easy touch 8 wireless and spa side remote.

  2. Back To Top    #2

    In the Industry
    JoshU's Avatar
    Join Date
    May 2007
    New Orleans, LA

    Re: Pentair Legend Platinum

    If the back-up valve fully cycles on and off at least once in a 5 minute period (or less) then the valve should be operating fine. When it fully cycles on it should pretty much stop the forward motion drive wheels of the cleaner.
    Josh Ulfers - TFP Supporting Vendor - - 888-725-8766 - AutoPilot Pool Pilot Systems, Parts & Cells - AquaCal Heat Pumps

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts