Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Heater problem Teledyne Laars EC 325

  1. Back To Top    #1

    Heater problem Teledyne Laars EC 325

    Just installed a new/used EC 325 (to replace a beyond repair EPC 400). We are very excited as we have lived in our home now almost one year and until now, haven't had a working spa. Install was very simple as the heaters are identical in configuration except the overall width (which was not an issue).

    Anyway, the heater fired up immediately, and the spa heated from 62-95 degrees in a little less than an hour - time to jump in!

    The temp selector was set on high for the initial heating. As the spa reached 100, I turned down the temp control and waited about 30 seconds until the heater shut off. Returned to the spa, and within one minute or so the, heater kicked back on.

    I then turned the temp control to the lowest setting, and waited again until the heater turned off. Returned to the spa, and the heater kicked on again. The spa reached 103-104, then I manually shut the heater "off". It seems the heater is sensing colder water than what the temp selector is set at?

    Anyone experienced a similar problem, or have any advice on where to troubleshoot? I have searched this forum, and other internet sources and was unable to locate any info on the same type of problem.

    I suspect a limit switch, but that's just a guess.

    Thanks in advance for any input!

    Jon
    IG Plaster 13,250 gal with attached (elevated/spillover) spa built in 1988?, sand filter Hayward S244T, Intelliflo VS-3050 pump, Fafco solar, broken gas heater, trichlor tabs for now.

  2. Back To Top    #2

    In the Industry

    ps0303's Avatar
    Join Date
    Jul 2011
    Location
    FL
    Posts
    3,436

    Re: Heater problem Teledyne Laars EC 325

    This heater has two temp control knobs, one for pool and one for spa. I'm guessing you turned the spa one on and had these issues. Try turning on the pool one and see if it does the same thing.

    Here is the manual on this unit.

    https://www.parts4heating.com/v/vspfile ... eries2.pdf
    Paul
    http://www.gastekservices.com A word of caution: When working with gas and electrical you might want to consider a licensed contractor. Consider the value of your life and others around you. If you would like to provide a review of the help I provided, please use the following link to leave a review. gastek - Google Search,

  3. Back To Top    #3

    Re: Heater problem Teledyne Laars EC 325

    Thank you for the reply, the control face of the heater only has a toggle switch for on/off, and one dial control for temp unlike the unit shown in the manual.
    I'll double check the model number, but I'm certain that is what is listed... thanks for the link to the manual, I'll also look at the trouble shooting section.
    IG Plaster 13,250 gal with attached (elevated/spillover) spa built in 1988?, sand filter Hayward S244T, Intelliflo VS-3050 pump, Fafco solar, broken gas heater, trichlor tabs for now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •