Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Hayward H350 Gas Heeater install question

  1. Back To Top    #1

    Hayward H350 Gas Heeater install question

    I am installing my pool heater and got power up to the unit. I have not installed the gas line or the plumbing yet. But right now I have no display on the panel. I at least expected something to come up on the display panel when I applied power to the unit? I don't want to go on with the rest of the install until i can figure that out. Any ideas?

  2. Back To Top    #2
    Christian's Avatar
    Join Date
    Jul 2012
    Location
    Sacramento, California
    Posts
    304

    Re: Hayward H350 Gas Heeater install question

    I would try checking the connections at the board to make sure there are no loose wires there.

  3. Back To Top    #3

    Re: Hayward H350 Gas Heeater install question

    My other question i guess is will it power up with no flow? Does the pressure switch prevent the display from coming up? I measured voltage out of the transformer and there is definitely not 120vac or 24 vac coming out of it.

  4. Back To Top    #4
    Christian's Avatar
    Join Date
    Jul 2012
    Location
    Sacramento, California
    Posts
    304

    Re: Hayward H350 Gas Heeater install question

    It should power up but the heater will not ignite until it checks it's order of operations. It needs to have power, gas, and flow to ignite (there are a couple others but these are the primaries). If it's getting power it should turn on and then give you an error code telling you why it won't ignite.

  5. Back To Top    #5

    Re: Hayward H350 Gas Heeater install question

    Thats what I was afraid of. Brand new heater just delivered. Seems like the transformer isn't putting out the correct voltage. Any ideas for that?

  6. Back To Top    #6

    In the Industry

    X-PertPool's Avatar
    Join Date
    Jun 2009
    Location
    Exeter, PA
    Posts
    1,385

    Re: Hayward H350 Gas Heeater install question

    I wouldn't even bother trying to fix it, just tell them the heater doesn't work and to pick up this one and give you a new one.
    -Kevin
    X-Pert Pool Service
    x-pertpool.com
    X-Pert Pool on Facebook and @XPertPoolServic on Twitter
    22,000 gal / 16' x 32' / Vinyl / Hayward s244t /Pentair SuperFlo 1 hp

  7. Back To Top    #7

    In the Industry

    Join Date
    Aug 2012
    Location
    Knoxville, TN
    Posts
    41

    Re: Hayward H350 Gas Heeater install question

    Check the incoming voltage power jumper. It should correspond with the line voltage you have powering the heater. They are clearly labelled 120v or 240v. If its wired for 240v incoming and the jumper is set to 120v you could have a fried board.
    Hot Springs certified service tech A
    APSP CST Certified
    CPO Certified

  8. Back To Top    #8
    Christian's Avatar
    Join Date
    Jul 2012
    Location
    Sacramento, California
    Posts
    304

    Re: Hayward H350 Gas Heeater install question

    I'm with Kevin, if you just bought it then I'd get it replaced under warranty.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •