Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Intex SWG Low Flow Problem

  1. Back To Top    #1

    Intex SWG Low Flow Problem

    I am new to pool-ownership; got my pool set up in July and have had LOTS of problems with it. I have done everything by the book, but kept getting Code 90. They (Intex) sent me a new pump; the Flow Sensor Conduit was leaking so they sent me a new one; that still didn't do the job (after I followed EVERY suggestion in the manuals) so they sent me a new SWG pump (except for the copper piece, which I cleaned in vinegar today); the pool was leaking at the output opening, which I changed out and now it no longer leaks. As you can see, I have tried EVERYTHING and am STILL getting a Code 90. I even put a brand new filter in today. I, too, kept getting air in the SWG pump so I tilted the pump to purge all the air. The only thing that has worked and allowed the pump to operate without that Code 90 is if I put it on its side (bottom of pump facing forward). Then I read in a couple of different places that that could possibly cause an explosion, so needless to say, it's back upright with the daggum thing beeping. I saw something about a magnet on the flow sensor. There is no magnet on either the original generator or the new one. Besides, wouldn't that keep the sensor open and potentially cause an explosion? I am at my wits' end!!! This pool has been practically entirely replaced, except for the copper electrode I need a larger pump? Would that do it? I'm using the one that came with the pool, so I would think that would provide adequate-enough flow. Any suggestions??? I am just disgusted, with all the problems I've had with this, I can count on both hands the number of times I've been able to enjoy my pool, and I live in hot-hot-hot Florida!!

    Intex Ultra Frame 16' x 48' AG 5,061 gallons
    Cartridge filter, 1,GPH pump, Intex Krystal Clear Saltwater System

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: Intex SWG Low Flow Problem

    Welcome to TFP.

    Post a pic of your setup. That will help us see if there's anything you could change to make the problem better.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts