Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: DE filter broken grids: How serious?

  1. Back To Top    #1

    Join Date
    May 2009
    Location
    Dallas, TX
    Posts
    781

    DE filter broken grids: How serious?

    So, while servicing the filter today I managed to break several grids. All broken in the same location: at the top of the grid, in the middle. I *think* this part is just structural...am I right? If so, the breaks would be no big deal. Filter seems to be functioning normally, but just wanted to run it by the board to see how bad I screwed up.
    [attachment=0:tn6pn31y]grid.jpg[/attachment:tn6pn31y]
    Thanks.
    Attached Images Attached Images
    20K gal IG plaster pool, Manually chlorinated with 6% bleach, 1.5 HP Sta-Rite Dura-Glas II pump, Pentair FNS Plus 48 DE filter, Polaris 280

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: DE filter broken grids: How serious?

    As long as the fabric is intact, it should continue to work. I found all 8 of the grids broken in the filter at my current house ... seemed to still work for awhile until the interface crushed and it be came impossible to reassemble.

    Posted from my Droid with Tapatalk ... sorry if my response is short
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. Back To Top    #3

    Join Date
    May 2009
    Location
    Dallas, TX
    Posts
    781

    Re: DE filter broken grids: How serious?

    Quote Originally Posted by jblizzle
    As long as the fabric is intact, it should continue to work. I found all 8 of the grids broken in the filter at my current house ... seemed to still work for awhile until the interface crushed and it be came impossible to reassemble.

    Posted from my Droid with Tapatalk ... sorry if my response is short
    Thanks for the response! That's what I thought...it's just a little piece that is broken.
    20K gal IG plaster pool, Manually chlorinated with 6% bleach, 1.5 HP Sta-Rite Dura-Glas II pump, Pentair FNS Plus 48 DE filter, Polaris 280

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •