Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Problems with Pump

  1. Back To Top    #1

    Problems with Pump

    I'm nearing the end of my first season as a pool owner. Haven't had a single issue all summer, until today. I came home today to find all kinds of junk in the pool from the trees surrounding the area. In a matter of 24 hours my skimmer basket and pump basket was full of this junk from the trees. By the time I saw it my pump wasn't moving much water.

    I cleaned out the skimmers and pump basket, but now when I turn the pump on, the pump basket never fills above about 75% capacity and the pressure back to my returns is very weak. What am I facing here?

    Any ideas are appreciated.

    Thanks
    25,000 gal plaster IG
    DE Filter
    Jandy SWG, 2.0hp Jandy Stealth pump
    DFW Area

  2. Back To Top    #2
    Mod Squad zea3's Avatar
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Posts
    9,200

    Re: Problems with Pump

    First question, did you clean the filter? When my DE filter is dirty flow through the returns has very little force behind it. Try opening up the filter and hosing all the old DE off the grids and out of the filter body. Recharge with fresh DE after cleaning. If that does not help, start looking for debris caught in the pipes or the pump impeller.
    TFP Moderator
    Helpful links: TF Test Kits,TFP Pool School, PoolMath
    Vogue 21' round AG, Pentair 1 hp 2 speed pump, 36 sq ft DE filter, Hayward S180T 150# sand filter, Houston, Texas
    Love TFP? Become a
    TFP Supporter!

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Problems with Pump

    Sounds like the basket being clogged & full exacerbated a suction side leak.
    Make sure the basket lid o-rings is clean & lubed. Then check the drain plug and any fittings.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  4. Back To Top    #4
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    Location
    SW Indiana
    Posts
    9,089

    Re: Problems with Pump

    A couple of possibilities would be a clog in the skimmer line, or debris in the impeller.

    Since the stuff got through the skimmer basket, there's a pretty good chance some got through the pump strainer. If you shut your pump off, you can often get your finger into the impeller through the hole in the pump strainer housing.
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  5. Back To Top    #5

    Re: Problems with Pump

    Quote Originally Posted by zea3
    First question, did you clean the filter? When my DE filter is dirty flow through the returns has very little force behind it. Try opening up the filter and hosing all the old DE off the grids and out of the filter body. Recharge with fresh DE after cleaning. If that does not help, start looking for debris caught in the pipes or the pump impeller.
    I back washed my filter 2 days ago, but haven't disassembled and cleaned it since May. My pressure has been great all Summer so I didn't see any need to do that yet.

    I haven't yet checked the impeller, but will do that when I get home.
    25,000 gal plaster IG
    DE Filter
    Jandy SWG, 2.0hp Jandy Stealth pump
    DFW Area

  6. Back To Top    #6

    Re: Problems with Pump

    Quote Originally Posted by zea3
    First question, did you clean the filter? When my DE filter is dirty flow through the returns has very little force behind it. Try opening up the filter and hosing all the old DE off the grids and out of the filter body. Recharge with fresh DE after cleaning. If that does not help, start looking for debris caught in the pipes or the pump impeller.

    I have not cleaned the filter but the pressure was ~10psi just 24 hours ago. 10 psi is my "clean" pressure so I think my filter is fine.
    25,000 gal plaster IG
    DE Filter
    Jandy SWG, 2.0hp Jandy Stealth pump
    DFW Area

  7. Back To Top    #7

    Re: Problems with Pump

    Impeller was indeed badly clogged. Once I got it cleared and fired it back up water was flowing good again.

    Thanks for the help everyone!
    25,000 gal plaster IG
    DE Filter
    Jandy SWG, 2.0hp Jandy Stealth pump
    DFW Area

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •