Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pool Pump is not drawing water from the pool

  1. Back To Top    #1

    Pool Pump is not drawing water from the pool

    I just replaced my old Hayward pool pump with the same 2 HP model. The problem is it is not drawing any water from the pool, even after I thoroughly primed the basket and intiake hose.

    What is the cause of this and how can I fix it?

    My name is Mike and I am brand new to this website.

    Please Help!

    Thanks,

    Mike
    AGP 8600 Gal Intex Ultra Frame 18x52
    Hayward S180T Sand Filter

  2. Back To Top    #2

    Re: Pool Pump is not drawing water from the pool

    Is it possible there is an air leak somewhere, maybe a missing gasket on the skimmer basket or a loose union? Skimmer basket gasket got me once.
    Dan's Pool: 40K gal gunite pool - 50 by 18 and 8ft spa, 2 Aquarite 40K SWG, Aquamatic pool cover (rarely used), 60sq ft De filter (Jandy), Heat Pump and Gas heater (rarely used), O3 generator, just started borates

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: Pool Pump is not drawing water from the pool

    Welcome to TFP.

    If it won't prime there has to be an air leak on the suction side. Maybe a missing or deformed o-ring.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •