Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Aquarite - Suntouch Remote Control

  1. Back To Top    #1

    Aquarite - Suntouch Remote Control


    I have recently installed a new Suntouch controller with Intelliflo VS pump and my original Aquarite SWG ( Cell T-15 )

    After many hours of trying to understand the Suntouch manual , everything is working according to plan except one thing, controlling the Aquarite SWG remotely.

    The Aquarite unit is rev 1.4 and has the Cell T-15. The unit working perfectly in manual mode generating chlorine. I tripled checked the com port wiring according to the manual.

    Aquarite ----> Suntouch
    Green Blk (gnd)
    Yellow Grn (-DT)
    Black Yel(+DT)
    Red Red ( +15)

    The remote control led never turns on. I have tried many combinations of settings since the manuals do not explain this scenario.

    Does anyone have this combination working and what are your settings for the SWG and Suntouch?

    Appreciate any assistance.

  2. Back To Top    #2

    Re: Aquarite - Suntouch Remote Control <solved>

    Thanks to a very helpful Pentair support person, the problem is solved.

    We went through all the settings on the Suntouch and confirmed correct.

    Still no communication.

    He suggested I change the 4 conductor wire to a shielded marine cable. I guess the marine wire is better in a humid environment. I purchased the wire from the local marine shop and replaced the wire from the "big box" shop.

    Bingo, problem solved. Moral: pay a little more on high quality cable and avoid this frustrating problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts