Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 16 of 16

Thread: New leak at filter multi-valve

  1. Back To Top    #1
    LauleaHere&There's Avatar
    Join Date
    Aug 2010
    Location
    Rural Moloka'i, Hawai'i
    Posts
    155

    New leak at filter multi-valve

    Could you guys help me diagnose? I just replumbed my system to include a solar heater, and took the opportunity to look inside my zeosand filter, rinse, etc. Now it's leaking from under the top where the valve handle is. Does this sound familiar to anybody? What should I look for?
    12' round above ground pool. 3,500 gal. Vinyl liner. Waterway Supreme Hi-Flo 48 frame pump. 1.5 hp. SWG. Sand filter with Zeobrite.

    Thanks, members of Trouble Free Pool, for being so friendly and informative!

  2. Back To Top    #2
    LauleaHere&There's Avatar
    Join Date
    Aug 2010
    Location
    Rural Moloka'i, Hawai'i
    Posts
    155

    Re: New leak at filter multi-valve

    Photo:
    Attached Images Attached Images
    12' round above ground pool. 3,500 gal. Vinyl liner. Waterway Supreme Hi-Flo 48 frame pump. 1.5 hp. SWG. Sand filter with Zeobrite.

    Thanks, members of Trouble Free Pool, for being so friendly and informative!

  3. Back To Top    #3
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: New leak at filter multi-valve

    Did you open up the valve while you were cleaning everything?

    I think the water can only get up where you are pointing to if there is something wrong with the spider gasket inside ... although then I would expect you to see water out the waste as well.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  4. Back To Top    #4
    LauleaHere&There's Avatar
    Join Date
    Aug 2010
    Location
    Rural Moloka'i, Hawai'i
    Posts
    155

    Re: New leak at filter multi-valve

    Thanks for answering, Jason. I only took the valve assembly off the tank, I didn't take it apart. And I am not getting leakage from the waste port. The big O-ring at the base of the valve assembly is in good shape. I lubed it good when I put the whole thing together a couple of years ago, and lubed it again before I reassembled the filter. I did notice a couple of things--when I turned on the pump, the valve assembly hissed a little; the inside column of pipe that covers the center pipe that leads to the laterals has rough edges; and the water that came out of the filter when I turned the pump on was cloudy. Does that help? Thanks!

    Renee
    12' round above ground pool. 3,500 gal. Vinyl liner. Waterway Supreme Hi-Flo 48 frame pump. 1.5 hp. SWG. Sand filter with Zeobrite.

    Thanks, members of Trouble Free Pool, for being so friendly and informative!

  5. Back To Top    #5
    LauleaHere&There's Avatar
    Join Date
    Aug 2010
    Location
    Rural Moloka'i, Hawai'i
    Posts
    155

    Re: New leak at filter multi-valve

    Also, if I chose to replace the whole valve assembly, how can I tell if what I buy will fit my sand tank?
    12' round above ground pool. 3,500 gal. Vinyl liner. Waterway Supreme Hi-Flo 48 frame pump. 1.5 hp. SWG. Sand filter with Zeobrite.

    Thanks, members of Trouble Free Pool, for being so friendly and informative!

  6. Back To Top    #6
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: New leak at filter multi-valve

    Well before you consider replacing it, I would certainly just open it up and see if something is obviously wrong inside. If it is like mine for the DE filter, there should just be about 8 bolts to remove to open up the top and try to see where the water is coming from.

    Posted from my Droid with Tapatalk ... sorry if my response is short
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  7. Back To Top    #7
    LauleaHere&There's Avatar
    Join Date
    Aug 2010
    Location
    Rural Moloka'i, Hawai'i
    Posts
    155

    Re: New leak at filter multi-valve

    Unfortunately, mine doesn't have bolts--I don't see an obvious way to get the top off.
    12' round above ground pool. 3,500 gal. Vinyl liner. Waterway Supreme Hi-Flo 48 frame pump. 1.5 hp. SWG. Sand filter with Zeobrite.

    Thanks, members of Trouble Free Pool, for being so friendly and informative!

  8. Back To Top    #8
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: New leak at filter multi-valve

    hmm. Well that kind of stumps me since if have not worked with the top mounted valves.

    Hopefully someone else may have some thoughts.

    Posted from my Droid with Tapatalk ... sorry if my response is short
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  9. Back To Top    #9
    LauleaHere&There's Avatar
    Join Date
    Aug 2010
    Location
    Rural Moloka'i, Hawai'i
    Posts
    155

    Re: New leak at filter multi-valve

    Thanks anyway, Jason. Much appreciated!
    12' round above ground pool. 3,500 gal. Vinyl liner. Waterway Supreme Hi-Flo 48 frame pump. 1.5 hp. SWG. Sand filter with Zeobrite.

    Thanks, members of Trouble Free Pool, for being so friendly and informative!

  10. Back To Top    #10
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: New leak at filter multi-valve

    What's the model number on the valve?
    I think it's twistlock and there's a lock pin you have to pull so you can turn it.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  11. Back To Top    #11
    LauleaHere&There's Avatar
    Join Date
    Aug 2010
    Location
    Rural Moloka'i, Hawai'i
    Posts
    155

    Re: New leak at filter multi-valve

    Bama, if there is a model number, I sure can't find it. There is a COD on the tank: 21786A. Both valve and tank are from Advantage Mfg, but I'm pretty sure that the valve is compatible with a Hayward 711 or 714T. Where would the pin be if there was one?
    12' round above ground pool. 3,500 gal. Vinyl liner. Waterway Supreme Hi-Flo 48 frame pump. 1.5 hp. SWG. Sand filter with Zeobrite.

    Thanks, members of Trouble Free Pool, for being so friendly and informative!

  12. Back To Top    #12
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,347

    Re: New leak at filter multi-valve

    I can't tell but that white piece sticking out the side of the cap might be it.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  13. Back To Top    #13

    In the Industry

    X-PertPool's Avatar
    Join Date
    Jun 2009
    Location
    Exeter, PA
    Posts
    1,385

    Re: New leak at filter multi-valve

    if it leaking from the arrow then it's SPX0714L COVER O-RING
    keep in mind you need to tighten these lids like a car tire. a little on each bolt on opposite sides until tight.
    if it's leaking directly from the handle then its O-RING SHAFT SEAL ASSY SP0714T,SPX0735GA O-Ring & Backup Ring

    this is all assuming it's truly comparable with the spx0714
    -Kevin
    X-Pert Pool Service
    x-pertpool.com
    X-Pert Pool on Facebook and @XPertPoolServic on Twitter
    22,000 gal / 16' x 32' / Vinyl / Hayward s244t /Pentair SuperFlo 1 hp

  14. Back To Top    #14
    LauleaHere&There's Avatar
    Join Date
    Aug 2010
    Location
    Rural Moloka'i, Hawai'i
    Posts
    155

    Re: New leak at filter multi-valve

    Kevin, thanks! I tried mounting the assembly again, being careful to tighten as you described. Wow! no leak at the arrow, but a teeny one at the collar. Still tentative about opening up the top, as that white "pin" seems to be pretty permanently installed. I don't want to pry it off with brute force and bust it up.

    I'm going to let the pump run for a few hours, and tomorrow I'll disconnect and try again with the valve assembly. Thanks so much for your help.
    12' round above ground pool. 3,500 gal. Vinyl liner. Waterway Supreme Hi-Flo 48 frame pump. 1.5 hp. SWG. Sand filter with Zeobrite.

    Thanks, members of Trouble Free Pool, for being so friendly and informative!

  15. Back To Top    #15

    Join Date
    May 2011
    Location
    Baton Rouge, LA
    Posts
    31

    Re: New leak at filter multi-valve

    Thanks for this post and thread. My Waterway multiport was leaking out the backwash port when I filled and opened this summer. So I took it apart expecting to see a problem with the spider gasket. The gasket was fine but the diverter valve was sticking in up position and just letting water blow by. I lubricated the o-rings and moving parts and put it back together and am happy that it is now working fine.
    IG SW Gunite, 15K Gals, Intelliflo pump with cartridge filter

  16. Back To Top    #16
    gtemkin's Avatar
    Join Date
    Jun 2008
    Location
    Seattle, WA
    Posts
    738

    Re: New leak at filter multi-valve

    Advantage Manufacturing has a website at http://www.advantageman.com

    They don't list manuals and I don't see a filter with the exact same multiport valve but you may want to check with them to help identify what you have and possibly get a copy of the manuals for your equipment.
    21K gal 16' x 40' in-ground pool built 1959, old school with Jacuzzi bronze pump, American Products 24" Sand Filter & Americana Multiport valve, Jandy Lite2 millivolt heater, Coverstar cover, and classic Kreepy Krauly.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •