Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: aquatrol problems rj version

  1. Back To Top    #1

    aquatrol problems rj version

    I'm having trouble with my aquatrol. Its about 3 yrs old and has been working fine all summer til now. While I was on vacation something happened and now when I have the timer on, the display goes balnk, pump will not turn on, and the only light is a flashing inspect cell light. If I turn the switch for the timer back off the display comes back on and just the power light is on which is the usual. I have taken and added chroline and plugged my pump straight In until I figure it out. I replaced the current limiter and no change. I found somewhere on checking the control box and found that the 4 wires coming out of the transformer have the right ohm load. The two yellow wires coming out do not read anything which the site said replace board. Is that my only solution. The fuse is also good. Please help.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: aquatrol problems rj version

    Welcome to TFP.

    Sounds like you've done your homework. Since everything is pointing to the board, I'd say it's time to change it.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Re: aquatrol problems rj version

    That's what I was afraid of. I also wanted to make sure it was the board and not the transformer.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts