Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Purex Titon MiniMax 400 Heater not working.

  1. Back To Top    #1

    Purex Titon MiniMax 400 Heater not working.

    Dear Pool Gurus,

    I have a MiniMax 400 heater (vintage 1995) which has been working fine since it's purchase/installation. Suddenly it is not performing. It will not 'heat' water passed 80 degrees. The unit has 4x indicator lights and 2x dials. Power light is on, Pressure light is on, Heat light is on, and Service light is off. Both Dials are set on Heat. When I turn the dials, I can hear the switch/ignition working. The MiniMax is indeed firing up, and heat is venting out of the top of the unit. But the water won't heat (passed 80).

    Any ideas or tips on what to try are appreciated.

    BTW, I did remove and inspect the "Minimax CH Flow Valve Assembly" (Part 19 in the diagram). Overall it looks fine. But oddly, inside this assembly was a deteriorated (maybe rubber) looking ball. Honestly I'm not sure if it is part of the assembly, or if this 'ball' worked it way into the valve by accident. Does anyone know it this 'ball' belongs in the Valve Assembly and/or can it be replaced if it is deteriorating?

    Thanks in advance for any advise.

  2. Back To Top    #2

    Re: Purex Titon MiniMax 400 Heater not working.

    Well, as Rosanne Rosannadanna would say... "Never Mind".

    The problem ended up being that the electric Jandy valve switch on the suction to the pump was inadvertently in the middle position (off) vs the down position. I must have knocked it when cleaning out the pump basket. Thus the jacuzzi was sucking in (colder) pool water, heating it, and returning it to the jacuzzi - never allowing it's water to get hot by recirculating it.

    Tho my family thinks I'm quite the 'Rock Star' for 'fixing it'.

    So obviously my pool equipment setup is pretty old (approx 17yrs) but still hanging in there. A few yrs ago, I rebuilt the pump (new seals and gaskets), and have replaced the grids in the DE filter a few times. Now that I've had a false heater scare, I should probably open it up and clean it up?

    Have a good one.

  3. Back To Top    #3

    Join Date
    May 2011
    Orange County, CA

    Re: Purex Titon MiniMax 400 Heater not working.

    Good job figuring this out and fixing your own stuff! Now you understand how the plumbing works when other issues arise (and they will!).
    38K in ground pool with attached spa. Current equipment: Easytouch 8 (521150) with IC-60 SWCG with web control by Autelis, 1x Pentair IntelliFlo 011018 pump (for filter), 1x Pentair 2HP WhisperFlo pump (for waterfall), 2X Pentair IntelliBrite 5G 12V lights, Pentair MiniMax400 NG Heater, Pentair SMBW2060 DE filter. Zodiac Barracuda MX8 cleaner on dedicated cleaner line. Lighting/home automation controlled by Insteon/ISY-99i.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts