Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Partially blocked return to waterfall / Polaris noise

  1. Back To Top    #1
    Montare67's Avatar
    Join Date
    May 2009
    Location
    Naples, FL
    Posts
    25

    Partially blocked return to waterfall / Polaris noise

    Hi all.

    Was out of town for a 10 days to find my pool caretaker took less than good care of the pool. They allowed the water to go below the skimmers (luckily was still set to draw from the bottom drain). Managed to get the valves all our of sync in trying to turn on the heater..... Had another friend (who owns a pool) stop over and resolve those issues. Two days before I returned we had the Derecho storm come through that blew a tree and 2 potted plants into the pool and no power for 5 days.

    I cleaned everything up and restarted the pump to find that the Polaris booster pump screeching like the bearings were shot - so I tore it down and found the ceramic seal/cup melted. Replaced the impeller, seal, cup and o-ring and started it back up, but the high pitched screech continues. Is the motor bad or maybe the bearings on the back of the shaft are shot?

    Also an issue with the waterfall having very low pressure. The waterfall is home run to the pump where 2 Ts split off to 4 2" lines going the waterfall, 2 returns, 4 deckjets, the Polaris cleaner. Pressure is good to the other returns, so it seems something is stuck in the waterfall return line. Filter pressure is 16-18psi and will go to 50-60 if i close off all but the waterfall. I get some water, but nowhere near were is should be.....Any suggestions how to clear an obstruction somewhere in the 60' of return line to the waterfall?

    Any suggestions before i call in the professionals?

    As always- great forum.
    thank you
    Eric
    24000gal IG Plaster, Jandy 2Hp, Jandy CL460 Cartridge, Polaris 280 w/booster

  2. Back To Top    #2

    In the Industry
    Qwaxalot's Avatar
    Join Date
    Jun 2012
    Posts
    439

    Re: Partially blocked return to waterfall / Polaris noise

    Try a drain king from the pump to the waterfall return line (with all other returns closed).
    In the industry, CSP (Certified Service Professional) by the NSPI and it's successor the APSP. My company services over 600 pools every year. I think the practices regularly espoused on this forum (especially the BBB method) are outstanding; however my comments will be often oriented towards the goal of getting it done, and getting it done right now!

  3. Back To Top    #3
    Montare67's Avatar
    Join Date
    May 2009
    Location
    Naples, FL
    Posts
    25

    Re: Partially blocked return to waterfall / Polaris noise

    Thanks - I thought about that, but was concerned with the 1/4" slit opening at the waterfall end that I may end up just pushing something further down the line and having it stuck behind the waterfall. I have no idea what could be intriduced into the piping after the filter/heater. I checked the check valve and the flapper/assembly is still in place.
    24000gal IG Plaster, Jandy 2Hp, Jandy CL460 Cartridge, Polaris 280 w/booster

  4. Back To Top    #4
    Montare67's Avatar
    Join Date
    May 2009
    Location
    Naples, FL
    Posts
    25

    Re: Partially blocked return to waterfall / Polaris noise

    I was able to fix the waterfall by cutting the line behind the outlet and found a mangled gasket from the check valve after the heater/filter.
    24000gal IG Plaster, Jandy 2Hp, Jandy CL460 Cartridge, Polaris 280 w/booster

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •