Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: newbie

  1. Back To Top    #1


    Hi Everyone,
    My name is Lin. I am new here. I am glad to have found you. I have a few issues maybe you could help me with. I bought a haywood navigator vaccume. When I try to use it i seem to get air in the pump so it looses its prime and the vac doesnt work . I bought a new bleeder for the filter which gets out the air but then the water shoots out and will not stop. Ater I bleed out the air I quickly put on the old one which will hold the water in. My old manuel vac seems to work ok. My son got the navigator to work for a little while but then we would loose the prime and it would lift off the bottom of the pool. I run the hose through the skimmer and make sure there is no air in the hoses and turn the skimmer valve to about 10 oclock. I know Something is wrong. I thought I read somewhere I should close the main drain valve while vacumming Is this so?
    I hope this isnt to confusing. I also need to change the lightbulb in the pool. How difficult is this to do?
    Thanks I appreciate any help you can give me.

  2. Back To Top    #2
    phipsi1237's Avatar
    Join Date
    Jan 2011
    North Las Vegas, NV

    Re: newbie

    The light isn't hard to do. It usually consist of 1 screw in the top of the chrome ring and a catch at the bottom behind the chrome ring. Remove the screw, and it should just pull out. There should be enough wire behind the light to remove it and set it on the side of the pool. Remember to turn the circuit breaker to the light off. Water and electricity don't seem to mix too well.

    As for the vacuum, I'm not the smartest. Could it be possible that one of the hose connections have a small hole? It could help with the main drain off, but with enough pressure, that shouldn't be an issue. Is the main drain and skimmer on the same valve?

    Also, if you could give us more details on what kind of vacuum you're using, that would be great.
    14.5K gal Plaster IGP, Intelliflo VS, EasyTouch 8, SWG, IntellipH, Clear and Clean 420 Cartridge Filter, Attached Spa, H400IDL2 NG Heater

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    SouthWest Alabama

    Re: newbie

    I bet you have a leaking hose on the vacuum. Inspect the hoses real close to see if you find a hole or split.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts