Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Leaking pump - new pool owners

  1. Back To Top    #1

    Leaking pump - new pool owners

    Well, we have a Jacuzzi LR 80980 pump for a small in-ground pool which is located in a three season sun room. The pool came with the house we purchased last year, so we are complete newbies at pool-ownership. We did manage to open the pool ourselves and deal with the water chemistry but are still battling cloudiness (after shock/floc and constant filtering) The pump had been working fine until recently. Then there was water on the floor. I have noticed a small leak at the bottom of the back of the pump. The leak continues all the while the pump is running. (pic 1)


    While looking further, I noticed the gap between two parts of the filter - see the area just above the red and blue band - there is a copper-colored spinning rod in there, and on the left hand side (in the photo) there is a large rubber piece/thick o-ring? that is spitting water out while the filter runs. Is this the source of the leak? Is this a matter of needing a new o-ring?
    We are not sure, and it seems to me that the pump may need to be disassembled (eep!) Any recommendations or insight would be so very greatly appreciated.

  2. Back To Top    #2

    Join Date
    Jan 2010
    Location
    Randleman,NC
    Posts
    620

    Re: Leaking pump - new pool owners

    look's like a shaft seal leaking
    Leasure bay AG 24ft,52 in high.installed June of 1999. Hayworth S-180 T sand filter/Power-Flo Matrix 1horse 2 speed pump /Aqua Trol SWG/Using TF-100 Test Kit

  3. Back To Top    #3

    Join Date
    Jan 2010
    Location
    Randleman,NC
    Posts
    620

    Re: Leaking pump - new pool owners

    The pump will need to come off the motor..Not sure with the one you have.Other's will post.You can pull it up on the internet for your pump..Put,It does look like the shaft seal need's to be replaced
    Leasure bay AG 24ft,52 in high.installed June of 1999. Hayworth S-180 T sand filter/Power-Flo Matrix 1horse 2 speed pump /Aqua Trol SWG/Using TF-100 Test Kit

  4. Back To Top    #4

    In the Industry

    X-PertPool's Avatar
    Join Date
    Jun 2009
    Location
    Exeter, PA
    Posts
    1,385

    Re: Leaking pump - new pool owners

    could be shaft seals and possible a housing gasket. If you have a motor repair shop in your area I would have them service it and probably get new bearings in the process as when the seal fails the bearings get wet and start to rust. Jacuzzi is out of business so some parts are getting hard to find.
    -Kevin
    X-Pert Pool Service
    x-pertpool.com
    X-Pert Pool on Facebook and @XPertPoolServic on Twitter
    22,000 gal / 16' x 32' / Vinyl / Hayward s244t /Pentair SuperFlo 1 hp

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •