Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Algae ring in skimmers

  1. Back To Top    #1

    Algae ring in skimmers

    Hello everyone
    I have been having a problem with a predominately black with a little bit of green build up around the inside of my skimmers. Assuming this is algae. I don't have it anywhere else except a little bit on the rail of my auto cover. Pool water is clear. Balancing is good except this year my free chlorine has been tough to keep consistent. I've used a lot of tablets. I have been using a sponge to clean my skimmers but I'm getting tired of doing it everyday. Does anyone know what,where why and how I can solve this problem.
    both skimmers get it & one is worse than the other

    20000 gal
    5 year old pool
    33x16 (21,000 Gallons) Vinyl Inground Pool, 1/2 HP Whisperflo, Hayward Sand Filter, Pentair Mastertemp 300, 1 AquaLamp, 1 Skimmer, 1 Main Drain and 4 Return Jets...Maintained with BBB Method

  2. Back To Top    #2

    In the Industry
    duraleigh's Avatar
    Join Date
    Apr 2007
    Sebring, Florida

    Re: Algae ring in skimmers

    If you have algae, your chlorine level is too low or has been too low in the past.. It really is that simple.

    Posting a complete set of test results will be helpful to try to get you more precise information.
    Dave S. - Forum owner
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts