Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Filter will not run

  1. Back To Top    #1

    Filter will not run

    The flap that is on the skimmer that leads to the filter keep getting stuck closed. This causes the filter to run dry. Now my filter will not run. the psi does not go above 0. That flow is all but a trickle and dirty water is coming out. How do I fix this?
    AG 15x30 4 ft deep 12000 gal.
    Aqua Star 100lbs Sand Filter model fs019
    Installed june 2012

  2. Back To Top    #2
    linen's Avatar
    Join Date
    Jul 2010
    Twin Cities, MN

    Re: Filter will not run

    The flap is called a weir, or weir door. You will have in inspect it to see if you need a replacement wier, or if something else is causing the problem. I think sometimes there is a stop on the skimmer that wears/breaks and then the weir door can get hung up on it.
    TFP Expert who uses Pool School and my TF100 test kit along with PoolMath for my: Round 11K gallon AGP with deep end, 20" sand filter, Matrix 1hp 2spd, 6 2ftX20ft solar panels (and solar cover!), Intex SWCG (copper bars disconnected) and a Rubadub hot tub (chlorine). The SLAM process is not finished until: 1. CC < 0.5 ppm, 2. An OCLT < 1.0 ppm and, 3. The water is crystal clear.

  3. Back To Top    #3
    MikeInNH's Avatar
    Join Date
    Sep 2007
    Southern NH

    Re: Filter will not run

    I've only seen mine get stuck for 2 reasons, either something is keeping it from dropping (pool toy or basket handle) or the spring that pushes the pins out to hold it in place is bad so it gets misaligned. When you say your filter will not run do you mean the motor runs but no water flow or it does not spin? Hopefully all you need to do is open the pump/strainer covers a bit to get the air out and water in, while pump is off of course.
    2007 1st full year with AG pool~15k gallons 18'x33' JW
    6/2010 added 2 button Intex SWG-painless except for when reset
    Switched to BBB from Baquacil (couldn't pay me to go back)

  4. Back To Top    #4

    Re: Filter will not run

    What is happening is the filter ran dry because thes kimmer do got stuck. Now the filter will not pump water. Psi is at 0. Flow coming out of return is very low and dirty.
    AG 15x30 4 ft deep 12000 gal.
    Aqua Star 100lbs Sand Filter model fs019
    Installed june 2012

  5. Back To Top    #5

    Join Date
    May 2012
    Montville NJ

    Re: Filter will not run

    First - is there water in the pump basket. The pump basket is the small canister (about the size of a coffee can) with the clear plastic top on it. Very slowly turn it to release the lock and then while keeping pressure on the lid, open the lid a little. This will let any air in there come out. When water starts to come out, push down on the lid and clamp it back on.

    If that seems a little much for you, you can put a winterizing plug in your skimmer (or turn off the suction side valve if you have one) then open the pump basket, fill it to the top with a bucket, close it back up and then remove the plug (or open the valve)

    The pump is not self priming - meaning if there is air in it, it will never start pumping untill you add an initial "charge" of water. When you pump began to suck air, it lost it's prime.

    Now, if you re-prime the pump and you still have problems, then we have to look at some other things (such as maybe you burned out your pump by letting it run dry)

    You should also be cleaning out that pump basket every so often as well. When you do that you do need to install the winterizing plug or turn the valve (if you have one) off. There is a strainer basket in that chamber that is intendend to catch anything the skimmer basket misses before it gets into your sand.

    27' Round ABG (17,000 gal) - +/- 11 hours of full sun per day
    Hard plumbed Hayward Perflex EC-40 DE filter w/ 1 HP pump (Got a new one June 2015)
    Filered 4 hours per day (on a timer)
    Pentair Aqualuminator - now working - and now dead once again, this time for good.
    Zodiac Wahoo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts