Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Intelliflo VF with Jandy RS upgraded to iAqualink

  1. Back To Top    #1

    Intelliflo VF with Jandy RS upgraded to iAqualink

    I've been trolling...and now it's time to ask the experts!

    I have recently installed an Intelliflo VF (latest and greatest version with 16 speeds, I believe). After installing it I then embarked on the process of forklifting the Aqualink RS. I ordered the iAqualink upgrade kit (IQ900-RS) and installed the board successfully. I thought I had hooked up the Intelliflo RS-485 connection to the Aqualink correctly since it's only two wires (green and yellow) assuming they could be placed on either 4-pin comm interface on the Aqualink board. The only thing the Aqualink sees is that the pump is "offline" and the Help section now shows an RS485 error with the pump.

    Is there something I need to do to be able to program and control the pump correctly?

    Also, my Aquarite was initially displaying the setting and salt level until recently (as it always has, even before the upgrade) but recently stopped. I'm guessing I have a bad communications wire between the units...I'll have to ohm it out later. But, if anyone has any suggestions, I'm listening.

    Pool specs:
    40,000 gallon gunite w/spa
    Hayward heater/60 ft2 filter
    Intelliflo VF pump
    Aqualink Rev R with iAqualink
    Two incandescent pool lights
    One incandescent SPA light
    Booster pump for Polaris 280


    Thanks...Russ

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Intelliflo VF with Jandy RS upgraded to iAqualink

    Welcome to TFP!

    The only thing that comes to mind is to make sure the pump is not in manual mode. Make sure Manual is not displayed, if it is press the manual button to turn off manual mode.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Re: Intelliflo VF with Jandy RS upgraded to iAqualink

    Pump is definitely in Filter mode. I was wondering if "Run Program" should be selected on the pump directly or if you should leave it off and let the Aqualink control it somehow. I think I tried this with no difference.

    Is my assumption about hooking up the RS485 yellow/green wires correct?

    Thanks...Russ

  4. Back To Top    #4

    Re: Intelliflo VF with Jandy RS upgraded to iAqualink

    I am curious if you get this running and how the programming works with the iAqualink. I ended up buying a Jandy VS FloPro just for the natural reason that similar product integrate better. I am starting to regret this decision as I have had 2 pumps fail in less than 3 months.

    I am at the point of trying to get all my money back on the VS FloPro and just go to the pump you are using - but I definitely would like the ability to program it via the iAqualink. Keep us posted!
    25K gal plaster IG pool/spa - Aqua Pure SWG - Jandy RS8 with OneTouch and iAqualink - 1.5HP Jandy Variable Speed ePump - Pentair 3 HP Spa Jet - Polaris 280 with booster - Pentair Cartridge Filter - 400K BTU MiniMax Heater

  5. Back To Top    #5

    Re: Intelliflo VF with Jandy RS upgraded to iAqualink

    I haven't yet had time to mess with it again. However, I am concerned that I lost all my RS484 communication between the Aqualink and the Aquarite, since I no longer see the status of the Aquarite on the Aqualink panel in the house. Wondering what was messed up...

  6. Back To Top    #6

    Re: Intelliflo VF with Jandy RS upgraded to iAqualink

    As someone just mentioned to me in a different thread:

    The Intellifo yellow wire goes to the black terminal on the Jandy RS485, while the green wire goes to the yellow terminal.

    In low voltage DC, if red is power, black is usually ground. Jandy didn't go this route, and instead used the high voltage AC standard of green being ground. Unfortunately Pentair and Jandy didn't agree on the colors, and oddly, the installation directions seem awfully lacking on this discrepancy.

    Derek
    saltwater AquaPure freeform pool from 2009. Now controlled via Aqualink.

  7. Back To Top    #7

    Re: Intelliflo VF with Jandy RS upgraded to iAqualink

    Derek--

    Thanks! You are da' bomb! Simply making those adjustments made my iAqualink display and control the pump correctly.

    I agree...there are not enough instructions on the electrical connections of the Pentair/Jandy combination. I will have to add to my blog @ Idoneitmyself.wordpress.com.

    Now I need to figure out why my Aquarite has stopped communicating with the Jandy Aqualink.

    Thanks again!

    Russ

  8. Back To Top    #8

    In the Industry

    Join Date
    May 2013
    Posts
    21

    Re: Intelliflo VF with Jandy RS upgraded to iAqualink

    Quote Originally Posted by RW5207 View Post
    Derek--

    Thanks! You are da' bomb! Simply making those adjustments made my iAqualink display and control the pump correctly.

    I agree...there are not enough instructions on the electrical connections of the Pentair/Jandy combination. I will have to add to my blog @ Idoneitmyself.wordpress.com.

    Now I need to figure out why my Aquarite has stopped communicating with the Jandy Aqualink.

    Thanks again!

    Russ

    Did you ever get the AquaRite to work? If not what revision of Aqualink are you running?
    Jandy iAqualink RS-8 Rev T, OneTouch, Chlorinator Translator, & AquaRite Rev 1.3

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •