Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Salt Generator not making chlorine

  1. Back To Top    #1

    Salt Generator not making chlorine

    I have a Hayward Aqua Rite salt generator that stopped making chlorine. When it is first turned on the control panel “no flow” light blinks for several seconds and then goes out, followed by the “generating light coming on for a few seconds and then going out. All other indicator lights are off, even the power light. I replaced the circuit board and display, but the problem still persists. Would the cell or flow switch cause this problem?
    Above ground, 30 foot circular pool, 20,000 gallons
    Hayward Swim Pro Voyager cartridge filter, 150 sq foot
    [s:18c5ymw7]2HP Hayward pump[/s:18c5ymw7] 1HP Waterway pump
    Installed in 2006? (just a guess, pool came with house I purchased in June 2012)

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,333

    Re: Salt Generator not making chlorine

    Welcome ot TFP.

    You don't have the percentage set to zero do you? If not, then it could be the transformer. Have you checked the voltage to the cell?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3
    NWMNMom's Avatar
    Join Date
    Apr 2007
    Location
    Waaay NW MN
    Posts
    1,582

    Re: Salt Generator not making chlorine

    18x33x52 Buttressfree Seaspray (Wilbar) AGP - 1.5hp Pentair Maxim w/22" Pentair Meteor Sand Filter, Aqua Rite SWG System, Biltmore Walk In Steps - 2/4x20 Solar Panel Setup - Doheny Jet Drive (RIP -Pool Rover Jr) - finally hard plumbed the whole darned thing -
    Beats Driving to the Lake!

  4. Back To Top    #4

    Re: Salt Generator not making chlorine

    I found the problem, but not the cause. The problem was a burned out ceramic capacitor.
    Above ground, 30 foot circular pool, 20,000 gallons
    Hayward Swim Pro Voyager cartridge filter, 150 sq foot
    [s:18c5ymw7]2HP Hayward pump[/s:18c5ymw7] 1HP Waterway pump
    Installed in 2006? (just a guess, pool came with house I purchased in June 2012)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •