Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 18 of 18

Thread: Ultra pure ozone generator not working

  1. #1

    Ultra pure ozone generator not working

    Went out today and noticed that my pool was green, yuck! Went over to the equipment and the little ball that usually bounces up and down in the tube on the ultra pure box wasn't moving and will not move. The equipment is about 5 years old, is this a typical lifespan? Is there anything I can check to get it to work?

    The information on the pool equipment readout doesn't show anything is wrong, I.e., the flow meter says its flowing, chlorinator, etc..

    Any ideas?

    I am really concerned about getting my pool back up to sparkling clean, the green has moved in quickly and I couldn't scrub it off.
    25,000 gallon saltwater pool with raised spa, Hayward de filter 6020, 2 hp pump, aqualogic PS-8 Controls - Dallas, TX

  2. #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    22,459

    Re: Ultra pure ozone generator not working

    The ozone generator failing likely had VERY little to do with your pool turning green.

    Post up a full set of test results and lets see if we can find the real reason for the algae showing up.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, Dolphin Diagnostic Robotic Cleaner, TF-100 test kit w/ SpeedStir
    Gone: Hayward RS1500 pump, undersized DIY solar heater, Dolphin Dynamic Robotic Cleaner
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. #3

    Re: Ultra pure ozone generator not working

    Total chlorine 3
    Free chlorine 1
    Ph 8.4
    Total alkalinity180
    Cyanuric acid
    25,000 gallon saltwater pool with raised spa, Hayward de filter 6020, 2 hp pump, aqualogic PS-8 Controls - Dallas, TX

  4. #4
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    22,459

    Re: Ultra pure ozone generator not working

    Did your last post get clipped off? CYA is the key number we are looking for.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, Dolphin Diagnostic Robotic Cleaner, TF-100 test kit w/ SpeedStir
    Gone: Hayward RS1500 pump, undersized DIY solar heater, Dolphin Dynamic Robotic Cleaner
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  5. #5

    Re: Ultra pure ozone generator not working

    The Cya is 30-50
    25,000 gallon saltwater pool with raised spa, Hayward de filter 6020, 2 hp pump, aqualogic PS-8 Controls - Dallas, TX

  6. #6
    Administrator JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    34,660

    Re: Ultra pure ozone generator not working

    Your PH is way too high. You need to bring down your PH to something more reasonable, say between 7.2 and 7.4 first. You never want to allow PH to go above 8.0, and preferably never above 7.8.

    It sounds like you have a saltwater chlorine generator. If so, your CYA level is way too low. CYA should be between 70 and 80 for use with a SWG. However, fix the algae problem first, then raise the CYA level.

    [shock:37qej83t]You need to shock the pool.[/shock:37qej83t]
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    TFP Admin. Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  7. #7

    Re: Ultra pure ozone generator not working

    What is the cc?

    We have a function called super chlorinator on our equipment display, should I use this?

    Yes, it is a sW pool. I don't really understand how to chock, I've read the information but still don't fully grasp it (I'm more artistic and kind of dense I guess).

    I will re read and try. I may have to end up enlisting a pool service.

    Thanks for all of your help!
    25,000 gallon saltwater pool with raised spa, Hayward de filter 6020, 2 hp pump, aqualogic PS-8 Controls - Dallas, TX

  8. #8
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    22,459

    Re: Ultra pure ozone generator not working

    Cc is combined chlorine, it is the "bad" stuff. According to your results, your cc is 2.0 (Tc=FC+cc)

    Do not use the SWG to shock. It adds the FC way to slowly even on super chlorinate and using that shortens the cell life. Use liquid chlorine and follow the instructions in pool school.

    If you have questions just ask as we have helped 100s through the process.

    Posted with Tapatalk ... sorry if I sound short ... hate typing on phone
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, Dolphin Diagnostic Robotic Cleaner, TF-100 test kit w/ SpeedStir
    Gone: Hayward RS1500 pump, undersized DIY solar heater, Dolphin Dynamic Robotic Cleaner
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  9. #9

    Re: Ultra pure ozone generator not working

    Ok, I'm going to give it the old college try, I added liquid chlorine. I will check the chlorine levels in the morning and see if I can post them and get a reply from someone. I will continue to scrub down the walls, though it doesn't seem to have much impact on the algae, maybe the chlorine will start to do some of the work.

    Thanks again for your help.

    I'm thinking I still need to get the ozone thing fixed on my pool? I think that is what turns the salt to chlorine?
    25,000 gallon saltwater pool with raised spa, Hayward de filter 6020, 2 hp pump, aqualogic PS-8 Controls - Dallas, TX

  10. #10
    Senior Member Isaac-1's Avatar
    Join Date
    May 2010
    Location
    SW Louisiana
    Posts
    4,177

    Re: Ultra pure ozone generator not working

    Like other's have said your green water issue is unlikely to be related to your ozonator, having said that these Ozonators are fairly simple inside, assuming it is not a blown fuse, there are really only a couple of parts that can fail, depending on the exact model you have it may contain a couple of long thin bulbs, as well as a fairly large heavy magnetic ballast, alternatively if a newer model it may contain one or two high voltage power supplies / transformers and a couple of small "starter" circuit boards in place of the ballast. If you understand how a fluorescent light fixture works then you understand one of these ozonators.

    Ike

    p.s. the Ozonator is not related to your salt water chlorinator, instead it offers a supplemental source of oxidation, I have one on my indoor pool to help keep CC build up low since it has very minimal UV light exposure from the sun.

    after rereading your post I suspect you have one of the newer style ozonators with the high voltage power supplies instead of the old style magnetic ballast as you have the newer style with the permanently installed flow meter (ball thing)
    Indoor 20x40 36,000 gallon vinyl pool with 1.5 HP 2 speed Jandy FloPro pump, Hayward EC75 Perflex DE filter, 11 4x12 Techno-Solis panel roof top solar heat with Aquasolar controller, Dolphin Diagnostic Pro Robot Cleaner. Also LMI metering chlorine dispenser pump and soon to be connected UV Ozonator and now Hot Spring Jetsetter standalone spa
    I use and endorse the TFtestKits TF-100 from http://tftestkits.net

  11. #11

    Re: Ultra pure ozone generator not working

    I replaced the transformer on my pump. Do you know if the transformer is specific to the ozonator, or a standard transformer? I will look at it tomorrow.
    25,000 gallon saltwater pool with raised spa, Hayward de filter 6020, 2 hp pump, aqualogic PS-8 Controls - Dallas, TX

  12. #12
    Senior Member In the Industry

    Join Date
    Apr 2007
    Location
    Raleigh, NC
    Posts
    21,803

    Re: Ultra pure ozone generator not working

    I'm thinking I still need to get the ozone thing fixed on my pool? I think that is what turns the salt to chlorine?
    No, the SWG does that. Assuming your pool is outdoors, the ozonator is not helping you....I would not fix it.
    Dave S.
    Site Owner 42k vinyl and concrete pool, 1.5hp pump, 140gpm filter, No SWG
    TFTestkits owner
    TFTestkits , PoolMath , Pool School

  13. #13

    Re: Ultra pure ozone generator not working

    Ok, this morning my readings are

    TC 5
    Fc 5
    Ph 8.4
    TA. 180
    Cya 0

    5 is the highest my test kit goes up to. It seems like the green is a little less intense this morning. Do I need to continue adding liquid bleach and/or shock to the pool? Is the hth shock n swim what I use? Can I add it during the day? We are getting temperatures in the upper 90's to 100.
    25,000 gallon saltwater pool with raised spa, Hayward de filter 6020, 2 hp pump, aqualogic PS-8 Controls - Dallas, TX

  14. #14
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    22,459

    Re: Ultra pure ozone generator not working

    CYA does not just drop from 30-50ppm to 0. what test kit are you using?

    Clearly you need one of the recommended test kits with the FAS-DPD chlorine test. Without it taking care of the pool is guys work.

    You need to get the CYA up to around 30 and then follow the shock process which requires you to maintain a FC well above what you kit will measure.

    Posted with Tapatalk ... sorry if I sound short ... hate typing on phone
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, Dolphin Diagnostic Robotic Cleaner, TF-100 test kit w/ SpeedStir
    Gone: Hayward RS1500 pump, undersized DIY solar heater, Dolphin Dynamic Robotic Cleaner
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  15. #15

    Re: Ultra pure ozone generator not working

    I think I must have initially measured the cya wrong. I have a test that has pool strips where you compare the colors on the bottle to the strip after dipping into pool.

    So I need one of the test kits where you add the different drops to the water?
    25,000 gallon saltwater pool with raised spa, Hayward de filter 6020, 2 hp pump, aqualogic PS-8 Controls - Dallas, TX

  16. #16
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    22,459

    Re: Ultra pure ozone generator not working

    Unfortunately the test strips are about the worst as far as accuracy and repeat-ability.

    See the link in my signature for a comparison of the test kits we recommend. The TF100 ends up being a better valve for the quantity of reagents you get. What is nice about the drop tests is there is very little open to interpretation. For many of the test you are just counting drops until the color changes.

    The test kit really is the best investments you can make to help you maintain your pool.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, Dolphin Diagnostic Robotic Cleaner, TF-100 test kit w/ SpeedStir
    Gone: Hayward RS1500 pump, undersized DIY solar heater, Dolphin Dynamic Robotic Cleaner
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  17. #17
    Senior Member Isaac-1's Avatar
    Join Date
    May 2010
    Location
    SW Louisiana
    Posts
    4,177

    Re: Ultra pure ozone generator not working

    The high voltage transformer is specific to the Ultra-Pure Ozonator, there is a place online you can buy parts:

    http://www.ozoneparts.com/

    Also parts sometimes show up on ebay at a much lower cost

    Ike
    Indoor 20x40 36,000 gallon vinyl pool with 1.5 HP 2 speed Jandy FloPro pump, Hayward EC75 Perflex DE filter, 11 4x12 Techno-Solis panel roof top solar heat with Aquasolar controller, Dolphin Diagnostic Pro Robot Cleaner. Also LMI metering chlorine dispenser pump and soon to be connected UV Ozonator and now Hot Spring Jetsetter standalone spa
    I use and endorse the TFtestKits TF-100 from http://tftestkits.net

  18. #18
    Junior Member In the Industry

    Join Date
    Aug 2010
    Posts
    9

    Re: Ultra pure ozone generator not working

    Hi argrza,

    My name is Brian and I work at UltraPure. Please give me a call and I will help you get this issue resolved.
    Brian Richardson

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •