Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: EasyTouch Help

  1. Back To Top    #1

    EasyTouch Help

    I am having trouble with my EasyTouch and I am finding that the manual not very useful (more likely I'm not very clever).

    I find weather I set a schedule or not my pump will eventually shut itself off (seems like after 24h but not confirmed) by itself and I need to manually turn it back on either at the panel or my remote.

    Any clues. I'm going away for two weeks and I need to make sure my SWG is working.

    Thanks a bunch.

    16x48 Above ground Intex, with 130 lb Dougboy sand filter 3/4 hp pump.
    6031 gallons

  2. Back To Top    #2

    Join Date
    Jul 2007
    Sahuarita, AZ
    I peeked at my program last night and all I could think of was if you're selecting every day of the week or not? When you create a schedule, you first choose the circuit to activate (in my case I select 'pool' to turn on the pump on the circulation speed), then select a start time, a stop time and the days of the week. You want to make sure you step through each day of the week with the right arrow button and make sure each day has the bar over the top of the letter indicating it's selected.

    Also, there are different types of programs you can make such as 'run once' or 'egg timer'... for a normal every-day program you want the mode: to say "schedule".

    Wait a sec, now that i read your post again, are you trying to set your pump to run 24h a day? Are you sure you need to? Thats the whole point of an automation system like the easytouch is to program schedules for different things. Generally 8-12 hours a day of pump run time is plenty to circulate your water. If you have an intellichlor SWCG then you can also set the run % for it from the easytouch controller... it's under settings ---> intellichlor.

    Generally the way to set a schedule is to start with the number of turn overs you want a day. A pool turn over means that if you have a 10,000 gallon pool then your pump has moved 10,000 gallons of water through the filter. If you pump 20,000 gallons of water through your filter in a day then you've done 2 turn overs. Usually between 1 and 2 turn overs a day is what people shoot for. You then set your pump run time to achieve that turn over. This can be tough because unless you have a flow meter plumbed in-line then it's difficult to tell how much water your pump is moving. If you post some details on your pool plumbing and equipment then we can try to help you estimate it. Usually though if a pool pump is sized appropriately, you should get between 1-2 turn overs with 8 hours of pump run time. The final step is to set your SWCG run % to generate sufficient chlorine for your pool. This is pretty much trial and error... start at 50% and monitor your chlorine levels daily. Bump the % up or down based on if you need more or less chlorine. Your target chlorine levels will depend on your CYA (stabilizer) levels but for SWCG's it'll likely be around 4-6ppm.

    With my system (in my sig) I run my pump 9 hours a day and have my SWCG set to 30%. This keeps me right around 4ppm of free chlorine. You'll likely have to adjust the percentage a couple of times a year as during the summer you'll burn off a lot more chlorine and will need to increase the % to keep up.

    I hope this helps...
    My Pool:
    12K gal IG gunite with 7' raised spa, gunite waterfall, PebbleTec Caribbean Blue finish, solar heating & in-floor cleaning system

    Equipment: Sta-Rite 300' Cartridge Filter, Intellichlor IC20 SWCG, Sta-Rite 400k BTU heater, Intelliflow 4x160 main pump & Sta-Rite 3/4 hp waterfall pump, EasyTouch controlls w/ wireless controller, TF-100 Test Kit w/ salt test.

  3. Back To Top    #3
    I have tried the schedule befoe but I tried again last night at around 6pm.

    I went into Pool, selected NEW schedule

    Setup the schedule for 4:00am - 11:00pm and confirmed on every day. No egg timer or one time, a real schedule.

    I confirmed that the pump was on. In my mind the pump should have turned off last night at 11pm and turned back on at 4am. When I came back in the morning at 8am the pump was off.

    Im at a loss.

    16x48 Above ground Intex, with 130 lb Dougboy sand filter 3/4 hp pump.
    6031 gallons

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts