Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Zodiak LM2 buttons not working

  1. Back To Top    #1

    Join Date
    Jun 2012
    Location
    Barrie, Ontario, Canada
    Posts
    28

    Zodiak LM2 buttons not working

    Hi everyone,
    I just purchased a home with a salt water pool, and I couldn't be happier to enjoy it everyday!
    However it seems there is a lot to learn before enjoying one of these babies.
    The pool is hooked up to a Zodiak LM2 SWG.
    In order to turn the power off to the unit (when I add salt), I have to unplug one of the wires to the Salt Cell electrode pack so (I have been told) that makes the machine not register any values, and also the cell packs do not work.
    After 24 hrs of adding the salt, i connected the wire to the salt cells and the machine started registering. However, there are 6 levels of salt output, and I was told to hve it on level 2, but the level that comes up is 3. I tried pressing the Output button to change the value and it doesn't seem to be working.

    I have not tried the Super Chlorinate button, as I am sure it is too soon to use it (if anyone can give me an approx. time after I put in the salt i could try the super chlorinate, that would be very grateful), so I am not sure if that button works or not.

    Has anyone else come across this problem, or may have a solution for it?

    Like I said this is my first pool, and even though I was given a small tutorial about the use of it, there is a lot to learn for it.
    If anyone has an vaulable links for salt water pools, that would be grateful appreciate too!

    Thanks everyone
    -Adam
    Size - 50,000 Litres / 13,208 g (32' x 16' x 4.5' Sport Pool)
    Filter - Jandy CL460 Cartridge Filter
    Salt Water - Zodiak LM2
    Pump - Jacuzzi Magnum Force
    Heater - Laars LT LT250NS-C
    IG Pool (Vinyl)
    2003-2005 ish

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,333

    Re: Zodiak LM2 buttons not working

    Welcome to TFP.

    Does the on/off button work to turn the unit on and off? You shouldn't have to unplug anything when adding salt. Just turn the unit off with the on/off button.

    The output button should increase the output with each press until it gets to the highest setting and then it starts over at the lowest setting.

    Does the "Chlorine Output" bar indicator work?

    Here's a link to the owners manual.

    Also, please post a full set of test results and how you got them? Knowing where you're located would be nice too.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Join Date
    Jun 2012
    Location
    Barrie, Ontario, Canada
    Posts
    28

    Re: Zodiak LM2 buttons not working

    Hi Bama.
    The on/off button nor the Output button work. The super chlorinate may work but I don't want to try it so early in the process. And all of the lights work on the machine.
    I have read thought the manual front to back and it doesn't say anything about the buttons not working.

    And I am in Ontario Canada
    Size - 50,000 Litres / 13,208 g (32' x 16' x 4.5' Sport Pool)
    Filter - Jandy CL460 Cartridge Filter
    Salt Water - Zodiak LM2
    Pump - Jacuzzi Magnum Force
    Heater - Laars LT LT250NS-C
    IG Pool (Vinyl)
    2003-2005 ish

  4. Back To Top    #4

    Join Date
    Jun 2012
    Location
    Barrie, Ontario, Canada
    Posts
    28

    Re: Zodiak LM2 buttons not working

    And I went to my local pool place for testing. Sorry I don't have the results handy
    Size - 50,000 Litres / 13,208 g (32' x 16' x 4.5' Sport Pool)
    Filter - Jandy CL460 Cartridge Filter
    Salt Water - Zodiak LM2
    Pump - Jacuzzi Magnum Force
    Heater - Laars LT LT250NS-C
    IG Pool (Vinyl)
    2003-2005 ish

  5. Back To Top    #5
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,333

    Re: Zodiak LM2 buttons not working

    If it were mine I'd want the buttons working. I'd also have to press the superchlorinate button just to see if it works. I suspect it won't.

    How old is the unit?

    Have you tried calling the mfg?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  6. Back To Top    #6

    Join Date
    Jun 2012
    Location
    Barrie, Ontario, Canada
    Posts
    28

    Re: Zodiak LM2 buttons not working

    The unit is about 7 years old I imagine. How long do these machines usually last for?

    And I haven't tried calling yet no. But am going to
    Size - 50,000 Litres / 13,208 g (32' x 16' x 4.5' Sport Pool)
    Filter - Jandy CL460 Cartridge Filter
    Salt Water - Zodiak LM2
    Pump - Jacuzzi Magnum Force
    Heater - Laars LT LT250NS-C
    IG Pool (Vinyl)
    2003-2005 ish

  7. Back To Top    #7
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,333

    Re: Zodiak LM2 buttons not working

    The controller should last a long time. The cells last about 5 years or so.

    There could be a loose ribbon cable inside the unit that's stopping the buttons from working.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •