Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 18 of 18

Thread: Hayward EC50AC filter leaking around main seal (black metal

  1. #1
    Junior Member
    Join Date
    Jun 2009
    Location
    Derry, ME
    Posts
    19

    Hayward EC50AC filter leaking around main seal (black metal

    Hello,
    I have a leak around the main seal of my Hayward DE filter. I've check the gasket for damage and the lip of the filter looks fine. I've taken the black band off and on several times and reseated the cover and made it as tight as I could but after 30 minutes it starts leaking again. Any ideas? Since I opened the pool this year I can't seem to raise the PH (TF100 reads pale yellow) no matter how much Borax I add. Could this have led to the problem (damage due to acidic water?)? Thanks in advance for reading my post.
    15x30 Esther Williams semi-inground
    Hayward DE filter with 1/2 HP super pump
    4 2x20 Sungrabber solar panels
    TF100

  2. #2
    Senior Member techguy's Avatar
    Join Date
    Jul 2010
    Location
    Antelope, CA
    Posts
    2,612

    Hayward EC50AC filter leaking around main seal (black metal

    Have you added any lube to the o-ring. I think it is called Jacks #327. I added some to my pumps strainer lid and it sealed right up. I have the same filter with the matching pump.
    -- Guy --
    10K gallons in 21' Round 52 inch wall Aqualeader AG, Hayward Power Flow LX 1.5 HP pump motor, Hayward Perflex EC50AC DE filter w/Cellulose, Wide mouth skimmer, 2013 new Diver Dan (craigslist) to replace the faded old Hayward AquaBug. TF-100

  3. #3
    Junior Member
    Join Date
    Jun 2009
    Location
    Derry, ME
    Posts
    19

    Re: Hayward EC50AC filter leaking around main seal (black me

    I don't see that mentioned in the owners manual. Has anyone tried this?
    15x30 Esther Williams semi-inground
    Hayward DE filter with 1/2 HP super pump
    4 2x20 Sungrabber solar panels
    TF100

  4. #4
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    20,994

    Re: Hayward EC50AC filter leaking around main seal (black me

    First, post a full set of test results.

    A lot of us use pool lube on any o-ring or gasket around the pool. It's common practice and it really works.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 1.5hp Dynamo pump. 24" Pentair Sand Dollar Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit
    You can stop SLAMing your pool when you pass the OCLT (You lose 1ppm or less FC overnight, & You have .5ppm CC's or less) & your water is clear.

  5. #5
    Junior Member
    Join Date
    Jun 2009
    Location
    Derry, ME
    Posts
    19

    Re: Hayward EC50AC filter leaking around main seal (black me

    OK, I'll do a complete test run tonight.
    15x30 Esther Williams semi-inground
    Hayward DE filter with 1/2 HP super pump
    4 2x20 Sungrabber solar panels
    TF100

  6. #6
    Junior Member
    Join Date
    Jun 2009
    Location
    Derry, ME
    Posts
    19

    Re: Hayward EC50AC filter leaking around main seal (black me

    Here's my numbers:
    PH 6.8
    FC 4
    TA 90
    CC 0
    CYA 80

    I performed an acid bath on the filter finger assembly. The pool store said the pressure inside the filter could be increasing over time and causing the leak (it runs leak-free for 30 minutes).
    I guess I'll be draining some of the water at some point to get the CYA down (I've been using pucks for three years but I see the light now). I just got my TF100 a few days ago.
    15x30 Esther Williams semi-inground
    Hayward DE filter with 1/2 HP super pump
    4 2x20 Sungrabber solar panels
    TF100

  7. #7
    Senior Member techguy's Avatar
    Join Date
    Jul 2010
    Location
    Antelope, CA
    Posts
    2,612

    Hayward EC50AC filter leaking around main seal (black metal

    Try adding one more crank of the wrench when you close the steel band. I read it takes two turns once the coils of the spring touch each other. This was in the owners guide. You can find it online.
    -- Guy --
    10K gallons in 21' Round 52 inch wall Aqualeader AG, Hayward Power Flow LX 1.5 HP pump motor, Hayward Perflex EC50AC DE filter w/Cellulose, Wide mouth skimmer, 2013 new Diver Dan (craigslist) to replace the faded old Hayward AquaBug. TF-100

  8. #8
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    23,166

    Re: Hayward EC50AC filter leaking around main seal (black me

    Lube the oring and covers well.

    I tighten the screw to snug ... then tap all the way around the band with a rubber mallet ... then tighten and tap ... repeat until the spring is tight after tapping.

    That is the best way to get the band on uniformly without having to really crank on it.

    Posted with Tapatalk ... sorry if I sound short ... hate typing on phone
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, Dolphin Diagnostic Robotic Cleaner, TF-100 test kit w/ SpeedStir
    Gone: Hayward RS1500 pump, undersized DIY solar heater, Dolphin Dynamic Robotic Cleaner
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  9. #9
    Junior Member
    Join Date
    Jun 2009
    Location
    Derry, ME
    Posts
    19

    Re: Hayward EC50AC filter leaking around main seal (black me

    Thanks for the suggestions folks. I've tightened and re-tightened several times. I've tried the rubber mallot trick too. No matter what I do it starts leaking after 1/2 hour. I bypassed the solar panels to eliminate the extra presssure they put on the filter but it didn't help. I will pick up some lube when I buy a new gasket tomorrow. I have to try a new gasket at this point I think ($35).
    15x30 Esther Williams semi-inground
    Hayward DE filter with 1/2 HP super pump
    4 2x20 Sungrabber solar panels
    TF100

  10. #10
    Senior Member techguy's Avatar
    Join Date
    Jul 2010
    Location
    Antelope, CA
    Posts
    2,612

    Re: Hayward EC50AC filter leaking around main seal (black me

    if you have not tried the lube only on the old gasket (and the store is convenient) you could try that before spending $35 on a gasket.

    That said, $35 on a new gasket and another $10-12 for the lube is not such a bad thing either, especially if it's a long trip to the store.
    -- Guy --
    10K gallons in 21' Round 52 inch wall Aqualeader AG, Hayward Power Flow LX 1.5 HP pump motor, Hayward Perflex EC50AC DE filter w/Cellulose, Wide mouth skimmer, 2013 new Diver Dan (craigslist) to replace the faded old Hayward AquaBug. TF-100

  11. #11
    Junior Member
    Join Date
    Jun 2009
    Location
    Derry, ME
    Posts
    19

    Re: Hayward EC50AC filter leaking around main seal (black me

    OK, I tried a new gasket and Jacks lube. It ran for several hours before leaking again??
    I'm really at a loss now on what can be wrong. The pressure went from 0 to 20psi in that amount of time. It seems I have two problems: The leak and the pressure building so fast. The pool store is pointing to the pressure rising as to the cause but the seal should be holding at 20psi even if does get to that level so fast. Does anyone have any other ideas or am I looking at a new filter at this point?
    15x30 Esther Williams semi-inground
    Hayward DE filter with 1/2 HP super pump
    4 2x20 Sungrabber solar panels
    TF100

  12. #12
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    20,994

    Re: Hayward EC50AC filter leaking around main seal (black me

    You're right about it should not leak at 20 psi no matter how quickly it gets there.

    At this point I'd try and pinpoint the exact place it's leaking. If you could post a pic of that place it might help figure it out.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 1.5hp Dynamo pump. 24" Pentair Sand Dollar Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit
    You can stop SLAMing your pool when you pass the OCLT (You lose 1ppm or less FC overnight, & You have .5ppm CC's or less) & your water is clear.

  13. #13
    Junior Member
    Join Date
    Jun 2009
    Location
    Derry, ME
    Posts
    19

    Re: Hayward EC50AC filter leaking around main seal (black me

    Thanks for the reply. It's tough to tell exactly where since there is a band of metal that wraps all the way around the seam that's leaking. I've cranked this as tight as I can many times over but eventually it starts leaking. It's been running for 5 hours now without leaking but it did this last night and in the morning it was leaking again. I have pretty good troubleshooting skills but this is driving me crazy. I'm also worried this was brought on by adding the solar panels this year.
    15x30 Esther Williams semi-inground
    Hayward DE filter with 1/2 HP super pump
    4 2x20 Sungrabber solar panels
    TF100

  14. #14
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    20,994

    Re: Hayward EC50AC filter leaking around main seal (black me

    Have you replaced the gasket?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 1.5hp Dynamo pump. 24" Pentair Sand Dollar Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit
    You can stop SLAMing your pool when you pass the OCLT (You lose 1ppm or less FC overnight, & You have .5ppm CC's or less) & your water is clear.

  15. #15
    Junior Member
    Join Date
    Jun 2009
    Location
    Derry, ME
    Posts
    19

    Re: Hayward EC50AC filter leaking around main seal (black me

    Yes, I replaced the gasket last night and coated it with Jacks Lube. It now runs longer without leaking but still does eventually. I bumped it this morning and the pressure went from 0 to 16.5 before it started leaking again a few minutes ago.
    15x30 Esther Williams semi-inground
    Hayward DE filter with 1/2 HP super pump
    4 2x20 Sungrabber solar panels
    TF100

  16. #16
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    20,994

    Re: Hayward EC50AC filter leaking around main seal (black me

    It almost sounds like a issue with the sealing surface, where the gasket seals it until the pressure gets up and then it leaks by it. I'd pull it apart and inspect the sealing surface really well for scratches, cracks, and nicks.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 1.5hp Dynamo pump. 24" Pentair Sand Dollar Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit
    You can stop SLAMing your pool when you pass the OCLT (You lose 1ppm or less FC overnight, & You have .5ppm CC's or less) & your water is clear.

  17. #17
    Senior Member techguy's Avatar
    Join Date
    Jul 2010
    Location
    Antelope, CA
    Posts
    2,612

    Re: Hayward EC50AC filter leaking around main seal (black me

    I have the same filter and my pressures, on my old gauge, were 14 psi clean and 24 max pressure dirty. That gauge died last year. My new gauge shows different pressures, I am using cellulose and I am a dedicated BBB person now. So, I have not seen any green since June2, the day I added new water to my new liner. So my pressures have not climbed above 18 on the new gauge.

    I would bump before 24 if I could but some days there was too much junk in the water and it would go to 24 before I could bump it. I had a battle with algae last year and some weekends were filled with power-off, bump, watch pressures go from 14-20, bump... lather rinse repeat. Once the time to go from 14-24 was lass than one hour, I would crack open the case, take the tubes out, wash the tubes with the garden hose, dump the yucky grey-green DE from the filter body (no permanent backwash plumbing), rebuild the filter, add DE and watch the pressures rise again. I repeated this process until the water was clear. I have learned that DE filters water impurities really fast... and this mean if you let your water get green, you will need to do a bunch of changes and cleans but if you dedicate the time, it's pretty quick from green to clean (one weekend, in my case).

    I do know, if there is ANYTHING in the grooves for the o-ring, it will leak. Especially if the the debris is under the o-ring. I have a tree (crepe myrtle) near the filter body and if it drops a flower or seed pod while the cover is off the filter body, it will leak.
    -- Guy --
    10K gallons in 21' Round 52 inch wall Aqualeader AG, Hayward Power Flow LX 1.5 HP pump motor, Hayward Perflex EC50AC DE filter w/Cellulose, Wide mouth skimmer, 2013 new Diver Dan (craigslist) to replace the faded old Hayward AquaBug. TF-100

  18. #18
    Junior Member
    Join Date
    Jun 2009
    Location
    Derry, ME
    Posts
    19

    Re: Hayward EC50AC filter leaking around main seal (black me

    @Bama: Thanks. I'm thinking maybe a hairline crack right in the area you speak of but it must be pretty small because I haven't found one yet. This filter is only three years old.
    @Techguy: Good advise on bumping and pressure readings. I've made sure there is no debris under the gasket but I'll check again.
    15x30 Esther Williams semi-inground
    Hayward DE filter with 1/2 HP super pump
    4 2x20 Sungrabber solar panels
    TF100

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •