Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Solar heater won't turn off at preset temp...

  1. Back To Top    #1

    Join Date
    Oct 2011
    Location
    Orlando, FL
    Posts
    77

    Solar heater won't turn off at preset temp...

    Hi everyone:

    I've not had any problems with my GL-235 Goldline control system until now. I have my pool set at 90, and for years, once that is satisfied, the Goldline tells my pump to shut off, and it has without fail, until now.

    For the past couple of days, it heats to 91 or even 92 and the pump keeps running (and the valve actuator is sending water to the panels). For grins, I dialed it down to 85 while it was running, and it shut off. But, it starts back up again after a while.

    The whole system is so simple, I know, but I am scratching my head as to where to look. The sensors? I could do resistance checks but that seems to be a failproof part. The relay? Such a simple device. The actual board going bad on the GL-235 perhaps? I don't know how to diagnose that.

    Any help would be appreciated!

    Mike
    Mike

    9500 gallon plaster/gunite pool w/waterfall, 1/2 HP 1sp pump, 120 sq-ft Cartridge Filter, 336 sq-ft EPDM Solar Panels, CPSC16 SWG, Boratized

  2. Back To Top    #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    37,389

    Re: Solar heater won't turn off at preset temp...

    I am guessing sensor. Check the wire and the connections for corrosion.

    Posted with Tapatalk ... sorry if I sound short ... hate typing on phone
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, ThePoolCleaner, TF-100 test kit w/ SpeedStir
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,331

    Re: Solar heater won't turn off at preset temp...

    I agree with JB, it's possibly the sensor, but it could be a bad connection of the sensor wiring. The result would be the same.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  4. Back To Top    #4

    Join Date
    Oct 2011
    Location
    Orlando, FL
    Posts
    77

    Re: Solar heater won't turn off at preset temp...

    Water temp sensor, not the collector sensor, I presume?
    Mike

    9500 gallon plaster/gunite pool w/waterfall, 1/2 HP 1sp pump, 120 sq-ft Cartridge Filter, 336 sq-ft EPDM Solar Panels, CPSC16 SWG, Boratized

  5. Back To Top    #5
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,331

    Re: Solar heater won't turn off at preset temp...

    Most likely the water temp sensor.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  6. Back To Top    #6

    Join Date
    Oct 2011
    Location
    Orlando, FL
    Posts
    77

    Re: Solar heater won't turn off at preset temp...

    Yep, I believe y'all are correct. I just measured the resistance of the water sensor, and the conversion says that there is about a five degree lower temperature than the actual temp of the pool water.

    I'm surprised a sensor can go bad.

    Thanks for the push!
    Mike

    9500 gallon plaster/gunite pool w/waterfall, 1/2 HP 1sp pump, 120 sq-ft Cartridge Filter, 336 sq-ft EPDM Solar Panels, CPSC16 SWG, Boratized

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •