Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pentair platinum psi side pool cleaner not moving?

  1. Back To Top    #1

    Join Date
    Sep 2011
    Location
    Montgomery Texas
    Posts
    89

    Pentair platinum psi side pool cleaner not moving?

    Hey guys everything going great with my new pool but..... Now the pool cleaner is not moving. I checked the booster pump its on. I also disconnected the side hose fitting and the screen is clear. Also no water movement in the hole where the fitting attaches. I'm thinking a clog. Any other ideas?

    Thanks Steve
    24X38'ish 23,500 gallon Geometric with 10x10 spa(12jets), Pentair IC40 SWG, Pentair intelliflow(pool-spa), pentair whispersflow 2HP(booster spa jets), Two Polaris 1.5 Hp blowers, Pentair Wisperflow XF 3HP(2 6 foot water falls), Pentair clean&clear plus 520, Pentair Master temp 400. Intelli PH acid dispenser, Intellitouch with iPhone and iPad control. Two 45000 BTU fire bowls and one 60000 BTU fire pit.

  2. Back To Top    #2
    Melt In The Sun's Avatar
    Join Date
    Oct 2009
    Location
    Tucson, AZ
    Posts
    3,899

    Re: Pentair platinum psi side pool cleaner not moving?

    Hm, that's strange since you said the booster is on. A clog is possible, but that seems unlikely given that the booster is after the filter (right?). Is there any valve that could be turned the wrong way?
    11,200 gal, Pebble-Tec; Tristar 2-speed 1hp - Swimclear 325 ft2 cart - SWG - A & A in-floor cleaner - Heat pump. For the poolside cooking, a Yoder Wichita and a Big Steel Keg!
    TF Test Kits -- PoolMath -- Pool School
    Make each day your masterpiece. - John Wooden

  3. Back To Top    #3

    Join Date
    Sep 2011
    Location
    Montgomery Texas
    Posts
    89

    Re: Pentair platinum psi side pool cleaner not moving?

    Sorry for the late reply. I thought it was cavitating a little due to how loud the pump was. So with that in mind I turned my pool pump up to max rpm and sure enough it primed and started moving normally. I also noticed a small leak at the front of the pump where the PVC attached at the front of the pump. I Resealed it at I haven't had and problems so far. Tanks for the reply. Steve
    24X38'ish 23,500 gallon Geometric with 10x10 spa(12jets), Pentair IC40 SWG, Pentair intelliflow(pool-spa), pentair whispersflow 2HP(booster spa jets), Two Polaris 1.5 Hp blowers, Pentair Wisperflow XF 3HP(2 6 foot water falls), Pentair clean&clear plus 520, Pentair Master temp 400. Intelli PH acid dispenser, Intellitouch with iPhone and iPad control. Two 45000 BTU fire bowls and one 60000 BTU fire pit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •