Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Ozonator transformer keeps blowing - any advice?

  1. Back To Top    #1

    Ozonator transformer keeps blowing - any advice?


    15000 gal salt pool with Delozone Eclipse 2 ozonator.

    Noiced that the ozonator was not working. Pool water tests fine, nothing out of the ordinary (excepts phosphates being high this week). Tested ozonator - primary (240V AC) power OK, no 110V output. Unwrapped transformer - burnt/broken wire. Replaced with new one. Worked for five minutes. Opened box again, tested - same problem. Fuse has never blown, supply voltage stable. Before I buy another transformer (~$60), does anyone have any suggestions. It's frustrating because I would expect the Eclipse fuse to go before the transformer.

    Secondary question. I'm not noticing any difference with the ozonator not working. Pool seems fine with me doing usual things with acid, baking soda etc. Need to add some PhosFree because phosphates are really high (is this something the ozonator assists with when working?) but other than that, all OK.

    Any advice appreciated.


    27' AGP, 52" walls (est 17100 gallon), vinyl, installed summer 2011
    1HP motor, 150 lbs Hayward sand filter, Hayward chlorine feeder

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: Ozonator transformer keeps blowing - any advice?

    Welcome to TFP!

    Ozone and phosphates have nothing to do with each other, don't interact.

    I would just stop using the ozone system. They serve no real purpose in an outdoor residential pool.

    I would also skip the phosphate remover. As long as you maintain appropriate FC levels it really doesn't matter if you have phosphates in the water or not.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Re: Ozonator transformer keeps blowing - any advice?

    I had a similar issue with my Ozone system (Eclipse 1). Luckily it was covered under warranty. The service guy came out, replaced the transformer and it blew again within minutes. He replaced it again, then the fuse blew. He replaced the fuse and then the transformer blew again. He messed around with it for another 30 minutes, then ended up coming back several days later and replacing the entire unit.

    If it goes out again and is not covered under warranty, I will probably ditch the system. I question whether it does anything.
    Phoenix, AZ
    Unknown pool size -Diving pool

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts