Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: sr2000na replaced wire harness but ... now no power :(

  1. Back To Top    #1

    sr2000na replaced wire harness but ... now no power :(


    we recently bought a house with an in ground pool and a Sta-Rite sr2000na heater. This spring it did not work - error code E01. a friend and i opened it out, cleaned out the mouse house and found & spliced back together a broken wire to the thermistor and presto - the heater worked. We noticed a lot of nearly chewed through wires so my husband and I ordered a new wire harness and spent the afternoon replacing it and the transformer that came with as pentair had changed the wiring from a 5 wire plug to a set of 3 wire and a 2 wire plug.

    Sadly, the control board does not even light up and of course the heater does not work. (we did reset the breaker)

    any tips/advice on how to start trouble shooting ? I know this is a long shot but a new heater is $$$ as may be the bill to pay someone to troubleshoot it ...


  2. Back To Top    #2
    Melt In The Sun's Avatar
    Join Date
    Oct 2009
    Tucson, AZ

    Re: sr2000na replaced wire harness but ... now no power :(

    Welcome to TFP!
    Not to sound silly, but can you put the old wires back in? That may be the path of least resistance. Other than that, I don't know what the problem could be.
    11,200 gal, Pebble-Tec; Tristar 2-speed 1hp - Swimclear 325 ft2 cart - SWG - A & A in-floor cleaner - Heat pump. For the poolside cooking, a Yoder Wichita and a Big Steel Keg!
    TF Test Kits -- PoolMath -- Pool School
    Make each day your masterpiece. - John Wooden

  3. Back To Top    #3

    Join Date
    Jun 2012
    western NY

    Re: sr2000na replaced wire harness but ... now no power :(

    If you have the old wiring harness you can use it to see if all the connections on the new one are going to the same place as the old one. I would suspect, with the wiring change you mentioned, that they may have changed the connection sequence on the terminals. You mentiond that this is a transformer powered setup. Is the power flowing thru all of the switches? A multitester or an automotive test light will be needed to determine this
    Unknown make 18' above ground (bought used in 1999) Sparco sand filter. Hayward 100,000 BTu heater. 2 speed pump

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts