Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 7 of 7

Thread: Looking for cause of copper readings

  1. Back To Top    #1

    Looking for cause of copper readings

    My pool has in the last few years started to give me regular copper and iron readings. I have no heater and do not use well water. I have noticed some rusting around the screws that hold the skimmer plate on. Is there a chance that copper screws could be putting copper in the water? I also do not use algacide.
    Dazed and Confused in new jersey. 21,000 gallon vinyl liner, inground pool, sand filter.

  2. Back To Top    #2

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,083

    Re: Looking for cause of copper readings

    I doubt the screws are a source for iron or copper because they are so small.

    Replace your rusty screws with new stainless ones

    Are you using any algaecides with copper?
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3
    Samantha Sabrina's Avatar
    Join Date
    Apr 2012
    Location
    Bloomsdale, Mo
    Posts
    346

    Re: Looking for cause of copper readings

    Since you are not using well water where does it come from?

    If it is city or county water that could very well be your source.

    If the water comes out of the tap, (city or county water), take a sample to a local pool, or water treatment store and have it tested, also, you can go to the city or county if that is your water source and they are required to provide you with a full and complete list of everything they use in their water treatment.

    If you are having water hauled in ask the hauler for where the water is comng from and go there for water treatment chemicals.

    Good Luck
    Samantha

    In the process of building for a 22' Intex Ultra Frame, (completion date up in the air at this point).
    We could not beat our backyard into submission so we "Buried It".

  4. Back To Top    #4

    Re: Looking for cause of copper readings

    No, actually I stopped using algacide awhile ago. Just try to regularly schock. It's pretty strange.
    Dazed and Confused in new jersey. 21,000 gallon vinyl liner, inground pool, sand filter.

  5. Back To Top    #5

    Re: Looking for cause of copper readings

    Yes, I'm definately going to get water checked. Not sure if it's considered city or county water but I'm defiantly going to get that tested. Thank you both for quick replays. This forumn really helps others out...
    Dazed and Confused in new jersey. 21,000 gallon vinyl liner, inground pool, sand filter.

  6. Back To Top    #6

    Join Date
    Aug 2010
    Location
    Dallas, TX
    Posts
    4,052

    Re: Looking for cause of copper readings

    Did you stop using the algacide before you started seeing copper? The copper added by the algaecide won't go away with time.
    Built in 1957 44,000 gallon in-ground, Wet Edge Primera Stone in Sky Blue, Intelliflo VF Pump, 600 lb. Pentair Triton II TR-100 Sand Filter, CircuPool RG 60 Plus SWG, TF-100 test kit
    If TFP has helped you, please click to SUPPORT TFP!

  7. Back To Top    #7

    Re: Looking for cause of copper readings

    No, about 5 years ago I started seeing staining on lining walls and started using vitamin c to get rid of it. But that just added to the roller coaster of keeping ph and chlorine in check. Stopped using algacide maybe 3 years ago. I also tried not to schock immediately after adding new water although this year I schocked within minutes of adding water. Last year and the year before I tried to schock 3-4 days after any new water added. Could the fact that I added water when I schocked be a major contributor?
    Dazed and Confused in new jersey. 21,000 gallon vinyl liner, inground pool, sand filter.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •