Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 9 of 9

Thread: AquaRite with T-CELL-15 Cloudy water from jets - Solved!

  1. #1
    Junior Member
    Join Date
    May 2012
    Posts
    4

    AquaRite with T-CELL-15 Cloudy water from jets - Solved!

    Live in the NorthEast...Just converted to a AquaRite Salt System. Water is balanced.. When the salt system turns on..cloudy water comes from the jets--picture attached. It gives a strong chlorine smell. It obviously is generating chlorine due to the readings below... The first few times it foamed up the pool like a bubble bath.. thought it may have been the algaecide..but it has been three weeks.. now it clouds the entire pool and leaves a foam on the top....once I shut the salt system.. the pool clears.. This is getting very frustrating! Anyone have any ideas? I did use liquid shock for the first time to open the pool prior to installing the salt generator (about 3 weeks ago).

    SOLUTION::::
    I noticed a lot of air in the pump basket..never had it before..So grasping at straws... I replaced the gasket on the union before the pump and the basket seal... air gone... cloudy water gone!!!!! Hope this can help someone in the future!

    [attachment=0:3aiq7wd0]cloudy.jpg[/attachment:3aiq7wd0]
    Attached Images Attached Images

  2. #2
    Mod Squad jblizzle's Avatar
    Join Date
    May 2010
    Location
    Tucson, AZ
    Posts
    22,459

    Re: AquaRite with T-CELL-15 Cloudy water coming from jets

    Based on the picture, I was going to ask if you had a DE filter and somehow had it on recirculate when adding fresh DE

    But, reading the post, sounds like this is a very transient thing. There is a chance that you are still getting a reaction to the algaecide, but I have to fade back into the corner to observe the experts on this one.
    Jason, TFP Moderator
    18k IG pebblesheen pool, Hayward ProLogic P4 w/ T-15 SWG, Pentair 1HP 2-speed Superflo, Hayward 6020 DE filter
    500 sqft Heliocol solar panels, Dolphin Diagnostic Robotic Cleaner, TF-100 test kit w/ SpeedStir
    Gone: Hayward RS1500 pump, undersized DIY solar heater, Dolphin Dynamic Robotic Cleaner
    Pool School + Test Kit + PoolMath = A TROUBLE FREE POOL
    If you found TFP helpful and we saved you money ... Become a TFP Supporter!

  3. #3
    Senior Member
    Join Date
    Apr 2007
    Location
    Ft Lauderdale, Florida
    Posts
    1,423

    Re: AquaRite with T-CELL-15 Cloudy water coming from jets

    Are you running the full flow through the cell or is it on a bypass? Usually, if there's not enough flow through the cell, you'll get this result. Sometimes, too, if it's too close to a gas heater (with the heater running), you can get this result.
    Sean Assam - Sean@teamhorner.com
    Commercial Products Sales Manager
    AquaCal Heat Pumps www.aquacal.com
    AutoPilot Salt Chlorine Generators www.autopilot.com

  4. #4
    Administrator JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    34,660

    Re: AquaRite with T-CELL-15 Cloudy water coming from jets

    I've found that that effect almost always goes away once you get your levels adjusted and a few days pass.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    TFP Admin. Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  5. #5
    Junior Member
    Join Date
    May 2012
    Posts
    4

    Re: AquaRite with T-CELL-15 Cloudy water coming from jets

    Full flow. No heater. Perflex 75 DE filter. Pressure is about 12 on the filter. The jets seem to have enough coming out. But interesting thought. I had 1 1/2 plumbing from my DE filter to my jets... When i installed the AquaRite I came right out of my filter from 1 1/2 thread to 2" pvc and plumbed in the flow sensor and cell in 2" ( at least 12" from the filter as stated in the instructions) Then converted back to 1 1/2 to go to the pool. Wonder if I need to put a length of 1 1/2 past the filter..in front of the cell/flow sensor to get the flow going a little faster? Any thoughts?

  6. #6
    Administrator JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    34,660

    Re: AquaRite with T-CELL-15 Cloudy water coming from jets

    That wouldn't make any difference.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    TFP Admin. Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  7. #7
    Junior Member
    Join Date
    May 2012
    Posts
    4

    Re: AquaRite with T-CELL-15 Cloudy water coming from jets

    Anyone have any ideas.. The picture is only the beginning... it takes over the entire pool and foams the top..cant see through it... something is wrong!

    Water seems balanced..a pool place suggested I treat for phosphates.. did that.. still clouds up/foams the pool when the salt system turns on. Has to be a reaction to something.. Don't want to drain and start over if it will happen after I go through all that expense!

    I purchased the TF-100 test kit... any suggestions on what I could look for with this kit?

  8. #8
    Administrator JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    34,660

    Re: AquaRite with T-CELL-15 Cloudy water coming from jets

    Please post a complete set of water test results. We might see a clue in the numbers.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    TFP Admin. Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  9. #9
    Junior Member
    Join Date
    May 2012
    Posts
    4

    Re: AquaRite with T-CELL-15 Cloudy water from jets - Solved!

    Solved

    SOLUTION::::
    I noticed a lot of air in the pump basket..never had it before..So grasping at straws... I replaced the gasket on the union before the pump and the basket seal... air gone... cloudy water gone!!!!! Hope this can help someone in the future!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •