Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 9 of 9

Thread: Issues with new Intex sand filter

  1. Back To Top    #1

    Issues with new Intex sand filter

    Hi all - I have a 15 ft x 48 inch Intex pool. Last year we had a lot of trouble with the paper filters and cheap underpowered pump so I just bought and installed the big, 2600 GPH Intex sand filter, which I got hooked up yesterday. I also run the separate Intex saltwater system.

    I have no pool cover (have read the Intex ones don't work well). I filled up the pool yesterday. As soon as it got filled, my neighbor, who's a nice guy but whose yard is all dirt and weeds, decides to mow. My pool now has a lot of dirt and small debris in it. I ran my new sand filter pump for 24 hours after adding my 110 pounds of salt per the instructions. There's still a log of dirt in the pool. If this sand filter is so great, why didn't it filter out all of the dirt....especially after running for 24 hours?!

    I did the backwash and then the rinse cycles before running the filter cycle for 24 hours total. I have not turned on my saltwater system yet, but it's job is not to filter out dirt.

    We had a lot of issues last year with low flow, dirty or unbalanced water, skimming constantly, etc. I really want this summer to be easier and the pool to be a pleasure, not a pain!
    Any thoughts on my sand filter and why I still have dirt in my pool?
    Thanks for any advice!
    14,000 gallon IG DiamondBrite pool with 2 ea. waterfalls and slide, Hayward Tristar 2.0 HP 2-speed pump, Hayward 3/4 HP waterfeature booster pump, Hayward 48sf DE filter, Hayward PS4 wireless controller, 1 skimmer and 4 returns, Polaris 280 pressure cleaner w/booster pump, 7 x 7 spa w/6 jets, TF-100 Test Kit w/speed stir

  2. Back To Top    #2

    Join Date
    Aug 2010
    Location
    Dallas, TX
    Posts
    4,052

    Re: Issues with new Intex sand filter

    Is the dirt suspended in the water, or settled on the bottom of the pool?
    Built in 1957 44,000 gallon in-ground, Wet Edge Primera Stone in Sky Blue, Intelliflo VF Pump, 600 lb. Pentair Triton II TR-100 Sand Filter, CircuPool RG 60 Plus SWG, TF-100 test kit
    If TFP has helped you, please click to SUPPORT TFP!

  3. Back To Top    #3

    Re: Issues with new Intex sand filter

    Robbie, thx for the reply. Dirt is on top of the water, suspended in the water, and on the bottom. The pump seems to be working and definitely is spitting water much more forcefully back into the pool vs our old pump (hopefully solving low flow issues) but I thought this filter would clean the water much better too.why the dirt isn't filtering out is a mystery....
    14,000 gallon IG DiamondBrite pool with 2 ea. waterfalls and slide, Hayward Tristar 2.0 HP 2-speed pump, Hayward 3/4 HP waterfeature booster pump, Hayward 48sf DE filter, Hayward PS4 wireless controller, 1 skimmer and 4 returns, Polaris 280 pressure cleaner w/booster pump, 7 x 7 spa w/6 jets, TF-100 Test Kit w/speed stir

  4. Back To Top    #4

    Join Date
    May 2012
    Location
    Phoenix, AZ
    Posts
    9

    Re: Issues with new Intex sand filter

    What does your gauge say when its pumping? Did you do the backwash rinse in the beginning? I live in AZ with dust and dirt everywhere and the 2650 sand filter does wonders on my pool. I'm just having to vaccuum it once a week. Did you buy number 20 sand? For comparison my pool specs are below. I had small(smaller then dust) particles in my pool after I switched to sand filter, I just hooked my old cartridge pump in the middle, with no pressure drop(more than I already have). Cleared up in a day. I then took the filter out of it, until I need it again.so my setup looks like this:
    inlet->sandfilter pump->cart filter pump->salt chlorinator-> outlet.

    If you are not using 20 sand or zeo, the sand won't catch much.
    16'x48" Intex Ultraframe Pool, 5000 Gallon(54451EG)
    Intex Krystal Clear Saltwater Salt Water Chlorine Generator (54601E)
    Intex 2650 GPH Above Ground Pool Sand Filter Pump (56671EG)

  5. Back To Top    #5

    Join Date
    Aug 2010
    Location
    Dallas, TX
    Posts
    4,052

    Re: Issues with new Intex sand filter

    Yeah, that's the other thing. I didn't say anything because I'm not directly familiar with that filter, but most sand filters need to be backflushed for several minutes before ever being put into filter mode. You are probably going to have to vacuum or use a floor cleaner to get the stuff off the bottom. Adding a little DE to the filter might be helpful, just add enough to the skimmer to raise the pressure by 1 PSI. No more!
    Built in 1957 44,000 gallon in-ground, Wet Edge Primera Stone in Sky Blue, Intelliflo VF Pump, 600 lb. Pentair Triton II TR-100 Sand Filter, CircuPool RG 60 Plus SWG, TF-100 test kit
    If TFP has helped you, please click to SUPPORT TFP!

  6. Back To Top    #6

    Join Date
    May 2015
    Location
    Winchester/Va
    Posts
    2

    Re: Issues with new Intex sand filter

    I have the Sand Filter & Saltwater system model #20110, ph, alkalinity and chlorine all good. Added salt all good too. Manual said to boost for initial set up. I set my timer for 6 hours so it would run for 12 and then went to hit the boost and nothing happens. Why?? Do I even need to boost with it being brand new water and chlorine levels good? I did shock it to get my chlorine up.
    22x52 Intex Ultra Frame
    and Sand filter pump with Saltwater system

  7. Back To Top    #7

    Join Date
    Aug 2012
    Location
    Orlando, FL
    Posts
    678

    Re: Issues with new Intex sand filter

    If you're sure your filter is not putting filter sand in your pool, then add some DE or cellulose to your skimmer basket, which will send it to your filter. You only need to add enough to raise the filter pressure 1psi above the clean pressure. Sand filters can only do so much. DE and cellulose help the filter retain finer particles. Search the forum, the exact details are here.
    Sharkline Reprieve 15x52 (3/14). Still using Intex 2650 Sand Filter with Hayward Power-Flo Matrix 3/4 HP pump (6/15). Solar Cover cut into strips for easy removal, (2) 2*10 Space Saver solar panels. Swim Jet HD Robot (by Aquabot) (3/15). Chlorine Liquidator (4 gal). 4 person hot tub. Hard pipe is the way to go for improved flow! Retired Lil Shark (3/15). Starite Max E Therm 333k BTU Propane Heater w/ 24 gal tank (7/15).

  8. Back To Top    #8


    TFP Guide
    jeffchap's Avatar
    Join Date
    Jun 2012
    Location
    Edmond OK
    Posts
    1,373

    Re: Issues with new Intex sand filter

    Quote Originally Posted by klh View Post
    I set my timer for 6 hours so it would run for 12 and then went to hit the boost and nothing happens. Why?? Do I even need to boost with it being brand new water and chlorine levels good? I did shock it to get my chlorine up.

    You don't need to boost, but if you want to, you have to hold the button down for a few seconds.
    25000 gallon free-form gunite
    Jandy Stealth pump/CL340 cartridge filter
    Pentair IC40 SWG
    Pentair MasterTemp 250HD heater
    Jandy AquaLink RS automation

  9. Back To Top    #9

    Join Date
    May 2015
    Location
    NE Fl
    Posts
    6

    Re: Issues with new Intex sand filter

    Maybe I'm missing something but Are you using a skimmer or just the suction port that's under the water that came with the pool?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •