Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 3 of 3

Thread: Hayward H350 Ignition and Mode button problem

  1. #1
    Junior Member
    Join Date
    Sep 2008
    Posts
    20

    Hayward H350 Ignition and Mode button problem

    I have an electronic ignition Hayward H350 gas heater and I'm having trouble for the first time this spring.

    When I turn it on, the heater tries to light (I hear the ticking from the ignition) but no dice. After a while, I get the "IF" failure code. The gas is turned on and the first thing I did was remove all the gas ports and blow them out. 2 of them were blocked by spider webs. Re-installed and there is no improvement.

    Also, I'm not sure if this is related but the Mode button seems to do nothing. I press it and it does not cause the heater to go into spa or pool mode. It stays with the Standby light on at all times. I'm pretty sure this was the case last year too and the heater still worked.

    Any ideas?
    Concrete (gunite) inground pool and spa
    Hayward H350 natural gas heater (electronic)
    Goldline Aquarite chlorine generator
    Hayward pumps
    Hayward Pro Series sand filter
    Goldline valve actuators

    Location: Toronto

  2. #2
    Senior Member chiefwej's Avatar
    Join Date
    Jun 2011
    Location
    Tucson
    Posts
    802

    Re: Hayward H350 Ignition and Mode button problem

    IF is ignition failure. I had that code with my heater and had to replace the igniter. I recall the part was about $40. If you have the manual look up the IF code, if not a bit of searching online should lead you to a repair manual for the heater.
    chiefwej
    Tucson, AZ
    19k gallon Pebble Tec pool/spa,Pentair Intelliflo VS, 2 hp Super II pump (for spa), Aqua Rite T-15 SWG, Pro Grid 60 DE filter, Hayward H400 & Solar heating

  3. #3
    Junior Member
    Join Date
    Sep 2008
    Posts
    20

    Re: Hayward H350 Ignition and Mode button problem

    Turns out the problem was the gas. We had the meter replaced in the late fall and the serviceman didn't connect the service to the pool heater. Always check the most obvious problems first!
    Concrete (gunite) inground pool and spa
    Hayward H350 natural gas heater (electronic)
    Goldline Aquarite chlorine generator
    Hayward pumps
    Hayward Pro Series sand filter
    Goldline valve actuators

    Location: Toronto

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •