Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pentair Temp Sensor Not working - already replaced once..

  1. Back To Top    #1

    In the Industry

    Join Date
    Jul 2010
    Ashford, CT

    Pentair Temp Sensor Not working - already replaced once..

    My temp sensor reads all over the place but mainly pegged at 255 degrees. I would expect that that means the circuit is Open or there is a short of some kind?

    I replaced the sensor last year and also have a new board in the Easytouch, but had the same problem with the other board and the other sensor. Just upgraded boards from 4 to 8 circuits and everything else works fine.

    Any way to test these sensors. Think they are like 10 OHMS.

    I have already removed and reset the sensor on the pipe and removed the control board on the Easytouch and check the connections there and all looks ok.

    It does from time to time just start working...

    Also looked at the Jandy sensor and the wires look much more protected and insulated at the sensor end.

    Any help would be appreciated. Blake
    25k 20x40 Gunite w/ integrated Spa & Caribbean Blue Plaster, Curved Bluestone Coping, Deck Jets
    Pentair Easy Touch/Wireless, Sta-Rite Intellipro SRVS Pump, Intellibrite Lights, & Pentair IC40 Cell, Sta-Rite 450sf Cartridge filter
    Heated from Central Boiler - Outdoor Wood Furnace & Triangle Tube Max Heat Exchanger
    ColorQ Pro

  2. Back To Top    #2

    Join Date
    Mar 2011
    Houston, Texas

    Re: Pentair Temp Sensor Not working - already replaced once.

    Sorry, this may not be much help, but I don't think these sensors last very long. One of mine failed after about 5 months. This is just one example though. Pentair, of course, replaced it free of charge.
    9,200 gal. Gunite Luna Quartz French Grey pool with spill over spa, two fountains on tanning ledge (rarely used)
    Pentair Whisperflo 2HP, Pentair CCP Cartridge 420 Sq. Ft., Polaris 280 with booster pump
    Pentair EasyTouch 4, RayPak LoNox 266k Natural Gas heater, Aqua Rite SWCG T Cell 9, Borates, TF-100 test kit

  3. Back To Top    #3

    In the Industry

    Join Date
    Mar 2011

    Re: Pentair Temp Sensor Not working - already replaced once.

    These sensors used to be rock solid, then pentair changed their design, or supplier. Now they are total ****. 99% of the time if you system is reading too high of a temperature the problem is likely the temperature sensor.

    BTW Jandy had problems with theirs for years. Pentar just decided to join them I guess.
    20X40 30,000 gallon gunite pool

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts