Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Speedstir question...

  1. Back To Top    #1

    Join Date
    May 2012
    Location
    Lexington, SC
    Posts
    125

    Speedstir question...

    I feel silly asking because everyone loves theirs...but I'm wondering if mine is working properly? I tried using it last night but the magnetic bar thing didn't move all that much. Is it possible I'm (retarded? - don't answer that!) doing something wrong? I ended up just not using it for my tests after trying it a few times because it seems like it'd get stuck in one spot. Probably user error.
    13,500 gallons
    Sand filter
    IG
    Plaster
    TF-100

  2. Back To Top    #2
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    18,768

    Re: Speedstir question...

    If it sticks or bounces instead of spinning, you just need fresh batteries.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  3. Back To Top    #3

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,083

    Re: Speedstir question...

    However, I saw in another post where you just got your kit, so if it turns out the batteries are not good, please PM me your name and we'll get that fixed.

    Sometimes, you can shake the tube and it starts to spin. It is not very vigorous but it should create a whirlpool about 1/2 to 3/4" deep in the tube when spinning.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  4. Back To Top    #4

    Join Date
    May 2012
    Location
    Lexington, SC
    Posts
    125

    Re: Speedstir question...

    Thanks Dave. It definitely didn't spin. I'll try new batteries and see if that takes care of it. I'll keep you posted. Thanks!
    13,500 gallons
    Sand filter
    IG
    Plaster
    TF-100

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •