Become a TFP Supporter Welcome to our new server and new forum software. If you have problems logging in to the new system, you should try resetting your password. Click HERE to do that. Pool School
Results 1 to 4 of 4

Thread: Cartridge Filter No Pressure on Gauge

  1. #1

    Cartridge Filter No Pressure on Gauge

    I have a new pool with Pentair C&C Plus 320. Pump is VS3050 (1200rpm). Gauge on Filter reads 0 pressure. System is purged and water is flowing. Shouldn't there "some" pressure? Lines are all 2". 19,800 gallon pool.
    N Virginia
    -Leisure Moroccan 38' Fiberglass
    -19,800 Gallons
    -Pentair EasyTouch 4 w/IC40 Chlorinator,VS3050 Pump, Clean&Clear Plus 320 Cartridge Filter,Prowler 720 Robot Cleaner
    -1 Skimmer/ 3 Returns/2 Drains/2" Piping
    -3 Fiberstar Pal Treo LED lights/Wirtran
    -TF100 TestKit

  2. #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    20,610

    Re: Cartridge Filter No Pressure on Gauge

    Not necessarily. Running at only 1200 rpm with a filter that large and all 2" lines your gauge may not register that low a pressure. Crank the pump up to about 3000 and it should read something. You can also get a 0-30 psi gauge and it will probably read a couple of psi.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 1.5hp Dynamo pump. 24" Pentair Sand Dollar Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit
    You can stop SLAMing your pool when you pass the OCLT (You lose 1ppm or less FC overnight, & You have .5ppm CC's or less) & your water is clear.

  3. #3

    Re: Cartridge Filter No Pressure on Gauge

    Whew... I feel better.
    N Virginia
    -Leisure Moroccan 38' Fiberglass
    -19,800 Gallons
    -Pentair EasyTouch 4 w/IC40 Chlorinator,VS3050 Pump, Clean&Clear Plus 320 Cartridge Filter,Prowler 720 Robot Cleaner
    -1 Skimmer/ 3 Returns/2 Drains/2" Piping
    -3 Fiberstar Pal Treo LED lights/Wirtran
    -TF100 TestKit

  4. #4
    Member jjslinger's Avatar
    Join Date
    Sep 2011
    Location
    Santa Rosa, CA
    Posts
    63

    Re: Cartridge Filter No Pressure on Gauge

    I have a setup similar to yours (Intellipro VS rather than Intelliflo); at 1500 rpm I also get a pressure reading of 0. Actually, if I stare at the pressure gauge carefully enough, it seems like it has a "stop" at 2 or 3 psi. So, I guess I can't really measure below that with my gauge anyway.
    16K gal IG 16'x28' pebble; Pentair Easytouch; Sta-Rite Intellipro VS pump; Sta-Rite 400 sq. ft. cartridge; 6 Heliocol Solar Panels; Aquamatic Cover; Legend pressure-side cleaner with Hayward booster pump.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •