Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Intex saltwater filter says "low flow"

  1. Back To Top    #1

    Intex saltwater filter says "low flow"

    I just got the pool filled up, put in the salt, attached the saltwater filter to my summer excapes pool (which has a side mount filter/pump so that was interesting) and let the pump run for 24 hours like the directions said to do before turning on the saltwater filter. About 30 minutes after turning on the new filter it's blinking saying "low flow" but the water is flowing great out of the return. I am a novice when it comes to all of this and am not sure what to do now.

  2. Back To Top    #2

    Join Date
    Oct 2011
    New Caney, Texas

    Re: Intex saltwater filter says "low flow"

    If your Salt water filter (SWCG) ? If it has its own pump it is possible that the pump in the skimmer is restricting flow. They make an adapter that allows you to remove the pump from the skimmer and connect the skimmer to your new pump. If the SWCG has no pump then the pump in the skimmer may not be strong enough to produce the flow needed.

    Posting you specs to your pool in your signature would help.

    Google Summer Escapes Skimmer Filter Pump Conversion Kit
    18' x 42" Intex (4786 Gal @ 80% capacity) Intex 8110 SWCG, 2000 GPH cartridge filter.
    Full Sun, Well Water, Borates at approx. 50
    TFTestKit-100--The Pool Calculator--Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts