Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Junk in the pool post filtering

  1. Back To Top    #1

    Junk in the pool post filtering

    I am a new pool user and learning - been working to fix home owners' 10 years of neglect! I have cleaned and set the filter (DE Filter / Hayward) and getting a lot of larger junk in the return. I'm wondering if a crack or similar would cause that? I know at least one of the 10-year old DE filters has a broken top piece.......
    22.8K gal, IG plaster, Tagelus TA-100D 100 gpm sand filter, 1 HP WhisperFlo pump, Rheem 266k BTU NG heater, Dolphin Dynamic 2002 robotic pool cleaner

  2. Back To Top    #2

    Join Date
    May 2007
    Location
    South Central NJ
    Posts
    3,192

    Re: Junk in the pool post filtering

    I would tear down the grid assembly, hose it off and look for holes and tears 1st. Then check the manifold, up pipe, and it's O-ring. There is also a bleeder that is supposed to be screened but sometimes isn't and is the source.

    Scott
    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  3. Back To Top    #3

    Re: Junk in the pool post filtering

    That's what I figured -will give it a try - thanks
    22.8K gal, IG plaster, Tagelus TA-100D 100 gpm sand filter, 1 HP WhisperFlo pump, Rheem 266k BTU NG heater, Dolphin Dynamic 2002 robotic pool cleaner

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •