Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Aqua trol cell "inspect cell" light illuminated not flashing

  1. Back To Top    #1

    Aqua trol cell "inspect cell" light illuminated not flashing

    The inspect cell light stays on continiously. I have cleaned it and it looks good. My salt level is at 2300. Will that cause the light to stay on? Of course the low salt light is on as well. Any suggestions?
    12k gallons, pebble tech, DE filter, SWG (inop?)

    Trying to learn!

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,879

    Re: Aqua trol cell "inspect cell" light illuminated not flas

    Welcome to TFP!

    How old is your unit? Either your salt level is way too low, or the cell has reached the end if it's lifetime and needs to be replaced. The AquaTrol requires a salt level of at least 2700 to work and the recommended level is 3200. On a fairly new unit your symptoms mean you need to add salt. On an older unit (3 or more years old) they might instead mean that the cell is old and has failed.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3
    Yukon Jack's Avatar
    Join Date
    May 2011
    Location
    Rose Hill, KS
    Posts
    94

    Re: Aqua trol cell "inspect cell" light illuminated not flas

    I've got an Aqua Trol and agree you need to get your salt up. I'm presently at 3,100 and mine is working well. Also, what is your water temperature?
    18x33 AGP, 17,300 gal, Hayward Sand Filter, 1.5 HP 2 Speed Hayward Pump

  4. Back To Top    #4

    Re: Aqua trol cell "inspect cell" light illuminated not flas

    Not for sure the exact age of cell as it was already in place when we bought the house. I will add more salt. I would have added more already but wasn't for sure if it would do any good with the cell not working. My water temp is around 78
    12k gallons, pebble tech, DE filter, SWG (inop?)

    Trying to learn!

  5. Back To Top    #5

    Re: Aqua trol cell "inspect cell" light illuminated not flas

    I have an AquaTrol and was looking through the manual the other day. It says the inspect cell light starts blinking after 500 hours of use as a reminder to check it. You hold the diagnostic button down for 3 seconds to reset it. A solid light means it needs to be cleaned or replaced.

    Salt at 2300 is way to low, though. If adding salt doesn't clear the error, you can try cleaning it per the instructions in the manual. You can download a PDF of the manual here: http://www.hayward-pool.com/prd/In-Grou ... -1___I.htm

    Good luck.
    Sue

    18' round Sharkline Matrix AGP / 8600 Gal. / sand filter / Aqua Trol SWG
    Pool owner since 2001. Thanks to TFP for helping me convert off Baquacil after six years!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •