Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Circupool readings

  1. Back To Top    #1

    Circupool readings

    Hello all,

    I've had my Circupool RJ20 up and running for about 3 weeks now and levels have been great through my own testing. However, it just occurred to me that I've not tried looking at the actual unit for its various readings yet. I tried doing so today but don't get any valuable information - I get a water temperature of 32 degrees and a "Salt OK" message rather than a specific ppm reading (the same message displays upon startup each time). The manual is rather vague on some of this, but I am simply holding in the OK button for 5 seconds to get to these readings. Am I missing something here? Is my unit working correctly?


  2. Back To Top    #2
    WestSidePool's Avatar
    Join Date
    Jun 2009
    Cincinnati, OH

    Re: Circupool readings

    I had that same issue with my CompuPool unit, they look identical.
    Mine turned out to be a faulty chip. After I replaced it, it read more accurately in both the salt and temp. Although I had to calibrate a little for my salt. Again you probably wont get an exact reading from the unit since they are known to be off.
    The best way to test for salt is still with the strips.
    I just rely on the strips for salt and my thermometer in the pool for temp.

    IG 17x33 Grecian - Vinyl Liner (21k gallons), Hayward Pro-Grid DE 4820 filter, Hayward Super Pump, CompuPool SWG CPSC36, TF-100 Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts