Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Pentair AmerLite and SpaBrite Lights Not Working

  1. Back To Top    #1

    Join Date
    Jun 2007
    Location
    The Woodlands, TX
    Posts
    25

    Pentair AmerLite and SpaBrite Lights Not Working

    I rarely use my lights, but had friends over and was showing them the pool. After about a minute from turning them on, all lights (spa and pool) went out. The pool lights (2) and the spa light (1) are on separate relays.

    I pulled each light and checked the bulbs for continuity with a multimeter - each checked out ok (not burnt). I then checked the relays in the EasyTouch panel and they checked ok. Each was confirmed to have control from the EasyTouch and power after actuated. I turned them on and off several times to confirm.

    I checked voltage at the bulb sockets and got none after actuating from EasyTouch. I must be missing something in the EasyTouch panel or bulb check by continuity is not reliable.

    Any help is appreciated.
    22,380 gl ig gunite, Pentair cartridge & pumps, Intellichlor SWG, 8' spa, flagstone sunshelf, stonescape midngt blu, duradeck

  2. Back To Top    #2

    Join Date
    Jun 2007
    Location
    The Woodlands, TX
    Posts
    25

    Re: Pentair AmerLite and SpaBrite Lights Not Working

    Tried a few more things and determined that the GFCI was tripping on the spa light. Guess this is the 120V circuit to both spa and pool lights.

    The spa light was dry when I checked the bulb. What else could be tripping the circuit?
    22,380 gl ig gunite, Pentair cartridge & pumps, Intellichlor SWG, 8' spa, flagstone sunshelf, stonescape midngt blu, duradeck

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,337

    Re: Pentair AmerLite and SpaBrite Lights Not Working

    If it's feeding the pool and spa lights, it could be any one or more of them causing the problem.

    If you disconnect the load side of the gfci and turn it on does it trip? Sometimes GFCI's just go bad.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  4. Back To Top    #4

    Join Date
    Jun 2007
    Location
    The Woodlands, TX
    Posts
    25

    Re: Pentair AmerLite and SpaBrite Lights Not Working

    Removed the load side of the gfci and it does not trip. Removed the spa load and it does not trip.

    There are three lights (circuits) connected through the gfci; 2 x pool lights and 1 x spa light. The pool lights work fine with no tripping of the gfci. The spa light trips the gfci every time.

    I removed the spa light and found water in it this time. Apparently, I did a poor job putting it back in last time.

    I removed the light bulb from the spa light, dried it out and could find a very small resistance in the light circuit with no bulb. The gcfi tripped without the bulb in the socket.

    Is there some kind of shunt that burns in when water gets in the light? What else could create a small resistance with no bulb to complete the circuit enough to trip the gfci?

    More importantly, can this be fixed without replacing the entire light and circuit?
    22,380 gl ig gunite, Pentair cartridge & pumps, Intellichlor SWG, 8' spa, flagstone sunshelf, stonescape midngt blu, duradeck

  5. Back To Top    #5
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    22,337

    Re: Pentair AmerLite and SpaBrite Lights Not Working

    Any dampness that's soaked into the wiring will be enough to trip the gfci. I'd try letting it dry out really well and see if that helped. Also, does the spa side go through any other junction boxes? If it does, there may be some moisture in it/those.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  6. Back To Top    #6

    Join Date
    Jun 2007
    Location
    The Woodlands, TX
    Posts
    25

    Re: Pentair AmerLite and SpaBrite Lights Not Working

    As far as I can tell, it is a home run from the light to the Easytouch panel. Nothing else in line.

    I used a gfci tester on the gfci and it tested ok. I guess if its working for the pool lights and tests ok, it must be ok and the spa light must be at fault.

    Will let it dry out for a few days (I can think of nothing else to check/do).
    22,380 gl ig gunite, Pentair cartridge & pumps, Intellichlor SWG, 8' spa, flagstone sunshelf, stonescape midngt blu, duradeck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •