Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Aquapure 1400 DC connection

  1. Back To Top    #1
    tomfinch's Avatar
    Join Date
    Mar 2012
    Location
    Las Vegas, NV
    Posts
    52

    Aquapure 1400 DC connection

    There are 3 pins that the DC cable hook up to and my center pin is real loose. Is this normal? It's loose enough to where I feel I could pull it completely out of the cell if I wanted to. The 2 screws are real tight that hold it in place. Any ideas?
    [center:2jd6lb8v]16,000 Gal., Plaster, 3.0 HP Jandy, Polaris UltraFlex2, Aquapure 1400 SWG, Fafco solar panels, Jandy Aqualink[/center:2jd6lb8v]

  2. Back To Top    #2
    tomfinch's Avatar
    Join Date
    Mar 2012
    Location
    Las Vegas, NV
    Posts
    52

    Aquapure 1400 DC connection

    Just an update and question.... I was given an O ring kit to replace the O rings around all 3 pins. The center Pin that connects to the DC cable was corroded on the inside of the cell to the point it was not touching the plates. Not sure why the inside of this one Pin had corrosion and the other 2 didn't. I think I pushed it in far enough that it's touching the plates for now but it's definitely a temporary fix. Is there anyway to replace this Pin so I don't have to spent $500 on a new cell? I'd like to get 1 more year out of this 3 year old cell.
    [center:2jd6lb8v]16,000 Gal., Plaster, 3.0 HP Jandy, Polaris UltraFlex2, Aquapure 1400 SWG, Fafco solar panels, Jandy Aqualink[/center:2jd6lb8v]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •