Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Problem with New Poolvergnuegen 2x suction

  1. Back To Top    #1

    Problem with New Poolvergnuegen 2x suction

    I have just purchased a Poolvergnuegen 2x suction.


    I have been pretty amazed at how well this thing tackles huge leaves, twigs, worms, chunks of mulch... But I'm having one problem with it.

    It works great in the deep end of the pool, however, in the shallow end its showing a flaw. When it drives, as it drags the hose along, it tilts in such a way that what is supposed to be the bottom is pointing upward a little. It looses suction against the bottom of the floor, so it just drives and doesnt suck anything up.

    It will turn around once more hose is in the shallow end and work fine, but it only actually works well in the shallow end about 25% of the time.

    Has anyone experienced this problem and found a solution? I feel like I have played with all of the weight position / suction level settings. I have been watching this thing clean for about 6 solid hours and cant seem to fix this problem.

    I feel like if i could re-gear it to drive more slowly and have more suction force against the floor, it would work much better.

    Thanks
    16,000 gal in-ground
    Pump: Hayward C48K2N143 1HP 230V
    Filter: DE Triton Nautilus FNS-36

  2. Back To Top    #2

    Re: Problem with New Poolvergnuegen 2x suction

    Well I fixed it, i cannot believe how simple it was. I had to take a length of house out.

    Now it's working as it should.
    16,000 gal in-ground
    Pump: Hayward C48K2N143 1HP 230V
    Filter: DE Triton Nautilus FNS-36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •