Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Problem with Polaris Caretaker

  1. Back To Top    #1

    Problem with Polaris Caretaker

    Hi, guys. New to the forum. But I appreciate the wealth of knowledge and information available. I'm in the Tucson area. I had the pool built in 2007, and I am doing my best to learn how to handle as much as possible myself.

    I have an issue and I've searched through the forum a bit to try and find the solution before posting. I got some ideas but still wanted to double check to choose the right solution. I have the Polaris Caretaker 5-port in-floor cleaner. I had some problems last year with the cycling of the pop-ups. It would get stuck in one section-not cycle. I cleaned the valves and the filter and that would fix it for a bit. But this year I can't get it to cycle. It keeps getting stuck in one section. And some of the pop-ups that come up now aren't in the 'regular' cycle....like a couple from this usual section and a couple from the next section in the cycle are up. I was wondering if maybe some of the gears are stripped. I haven't disassembled the valve....thought I'd get some ideas first. Maybe a rebuild kit would fix it?

    Apologies upfront for novice mistakes in posting or vocab. I'll get the hang of it....

    Any ideas would be greatly appreciated.

    Thanks,
    Rob
    17000 Gal 15'x30' Pebbletec pool; Pentair Cartridge filter; Whisperflo 2hp Pump; Polaris Caretaker 5-port valve in-floor cleaner; SWG

  2. Back To Top    #2

    In the Industry

    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    30,403

    Re: Problem with Polaris Caretaker

    Hi, Rob,

    Welcome to the forum. Your post is in the right spot and your "lingo" is perfect!! Sorry I can't be of help.....I have no knowledge of them other than to say, sadly, in-floor cleaners seem to be somewhat troublesome across the board.
    Dave S.
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3
    lmigoni's Avatar
    Join Date
    May 2016
    Location
    Oro Valley, Arizona
    Posts
    17

    Re: Problem with Polaris Caretaker

    Hello Rob,

    Were you able to resolve the issue?
    Migoni
    20,000 Gallon in-ground PebbleTec pool, 1.5 HP Pump, Pentair Quad DE-80 filter, In-Floor Cleaning CareTaker, city water, K-2005 test kit.

    My Real Helmet assemble, paint and collect

  4. Back To Top    #4

    Join Date
    Nov 2017
    Location
    Clearwater, florida
    Posts
    43

    Re: Problem with Polaris Caretaker

    This problem can be easily fixed with a valve rebuild kit. I have to rebuild mine every 3-5 years. Fortunately, I have a lifetime warranty.
    30k, 20x40 freeform with spillover spa IG, Pebble sheen finish, Gold line SWG, DE filter, Caretaker in-floor cleaner, Screened in pool

  5. Back To Top    #5

    Join Date
    Jul 2011
    Location
    Scottsdale, AZ
    Posts
    54

    Re: Problem with Polaris Caretaker

    agreed with Mitchell. Haven't had to rebuild my caretaker at my new pool, but had my A&A rebuilt with a kit and worked very well (and still does after 7 years). It's basically just the internal gears that start going bad over time and don't allow one or more zones to close so that the next can open.
    15,000gal IG Stonescapes Mini Pebble Aqua Blue | Pentair CCP520 Cartridge Filter |
    Pentair Intelliflo VS | Robot TBD |

    12,000gal IG Plaster Pool <> Sta-Rite System 3 S7D75 D.E. FILTER <>
    Hayward Ecostar VS <> A&A In-floor Sytem <> IG Spa <>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •