Become a TFP Supporter Welcome to our new server and new forum software. Pool School
Results 1 to 8 of 8

Thread: Jandy lxi not heating, getting ignition fault, help

  1. #1
    Junior Member
    Join Date
    Oct 2011
    Posts
    10

    Jandy lxi not heating, getting ignition fault, help

    We had a Jandy lxi installed mid-winter in our home in Northern California. We turned it on and tested it after it was installed and it worked great. We used it one other time since then and it worked fine then too.

    It's been months since we turned it on but today we tried turning it on and it didn't work. Turns on, sounds like it's starting up. I can feel the blower going out the top but it's cool air. The blower begins before the ignition. I heard the gas flare up kind of like when it lights the pilot light so it sounds like it's lighting. The air temp didn't change during this process. Then we smelled gas for about 20 seconds, then it did the woosh sound again and sounded as if it lighted again. It tries three times and shuts off with an check ignition fault message.

    What can/should I check on this thing?
    35,000 gallons
    Sta-Rite Cartridge filter S3 System
    In-ground, gunnite pool w/ tiles
    No idea on pump size or rate at the moment

  2. #2
    Member
    Join Date
    Feb 2012
    Location
    Stowe, VT
    Posts
    58

    Re: Jandy lxi not heating, getting ignition fault, help

    I suppose it could be a number of things. Do you have a VOM to check for voltage and resistance?
    69,000 Gal gunite indoor IG pool.
    5 HP Emerson - Pentair Triton II Commercial TR140c Sand Filter x2
    5,000 Gal gunite outdoor IG hot tub
    2 HP Sta-Rite - Pentair Triton II Commercial TR140c Sand Filter

  3. #3
    Senior Member In the Industry
    Pool Clown's Avatar
    Join Date
    Sep 2008
    Location
    Silicon Valley, CA
    Posts
    801

    Re: Jandy lxi not heating, getting ignition fault, help

    I think either you're not getting flame rectification, or your igniter is not heating up(open). when you get the "whoosh", do you get any heat out of the exhaust? You wouldn't get much heat, just enough to get a change in temp. If you get no heat, igniter. If you get a little heat, rectifier. If this heater is less than a year, it should be warranty. If it is warranty, don't touch it. You may inadvertently void warranty poking around in there.
    Factory Warranty Station for:
    Jandy, Pentair, Sta-Rite, Raypak, Polaris,
    and Paramount pool cleaning systems.

  4. #4
    Junior Member
    Join Date
    Oct 2011
    Posts
    10

    Re: Jandy lxi not heating, getting ignition fault, help

    No heat at all, not a single bit. I tested it a few times now and even when my hand is there during the woosh there isn't a temp change. Thanks. I will have them check the igniter. Thanks for the tips!
    35,000 gallons
    Sta-Rite Cartridge filter S3 System
    In-ground, gunnite pool w/ tiles
    No idea on pump size or rate at the moment

  5. #5
    Senior Member
    Join Date
    Apr 2009
    Location
    Burlington, ON, Canada
    Posts
    310

    Re: Jandy lxi not heating, getting ignition fault, help

    If I'm not mistaken (it's been a while since I had to tinker with mine) you can take the front cover off and look through the sight glass into the burner area, and you should be able to see the igniter glowing during the ignition cycle, if it's working properly.
    16x28 Roman, 55000 litres, salt water, Zodiac Duoclear 130 (mineral cartridge removed!!!), inground, vinyl liner
    Hayward Tri-star 1HP (1.85) pump, Hayward sand filter
    Nine Fafco Sunsaver 4x10 solar panels, Jandy LX 250 natural gas heater
    Jandy Aqualink PDA with Sub Panel Power Centre

  6. #6
    Junior Member
    Join Date
    Oct 2011
    Posts
    10

    Re: Jandy lxi not heating, getting ignition fault, help

    RCY - Thanks, we will try that today
    35,000 gallons
    Sta-Rite Cartridge filter S3 System
    In-ground, gunnite pool w/ tiles
    No idea on pump size or rate at the moment

  7. #7
    Senior Member In the Industry

    Join Date
    Jul 2011
    Location
    FL
    Posts
    1,240

    Re: Jandy lxi not heating, getting ignition fault, help

    It should still be under warranty, at least 1 year. Mess with something and screw it up and you could void the remainder of the warranty. Call and get a tech out to look at it. Why waste your time and money for parts.
    Paul
    http://www.gastekservices.com

    A word of caution: When working with gas and other things you really might want to consider a licensed contractor. Consider the value of your life and others around you. I recently looked at a burned up heater at a customers house and found out he tried to trouble shoot it. He said he's not sure what he did but the unit caught fire. The unit is now toast and is being replaced. I'm only providing you with help but in many cases you need to hire someone. I realize people are all about saving money but lives are priceless!

  8. #8
    Member
    Join Date
    Feb 2008
    Location
    Dallas, TX
    Posts
    60

    Re: Jandy lxi not heating, getting ignition fault, help

    I had a similar problem with my 5 year old LX. The problem was a corroded and collapsed burner tube. The result was a backfire which caused the second "whoosh" sound and starved the oxygen supply causing the shutdown.

    What error codes are you seeing on the panel?

    Take the front panel off and observe the entire cycle from at least 5 feet away. If there is no backfire, then observe the igniter through the small glass window. If it doesn't glow then you have a problem with the igniter or the igniter circuit.
    31000 Gal IG L-shape w/ spa, Riversand finish (PebbleSheen clone)
    Jandy 60 sq ft DE, 2.5 HP (uprated) Stealth pump, Polaris 280 w/ booster, Jandy PDA PS4 controller

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •